[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: unable to resize ext3 partition - thinks its ext2...

From: Andrew Clausen
Subject: Re: unable to resize ext3 partition - thinks its ext2...
Date: Thu, 11 Mar 2004 08:42:33 +1100
User-agent: Mutt/1.5.4i

On Sat, Mar 06, 2004 at 02:15:33PM +0000, Nicholas White wrote:
> I have parted 1.6.6 running on redhat 9.  I would like to resize this ext3 
> partition, but when I tried it gave the output:
> (parted) resize 2 38162.219 48162.219
> Error: Filesystem was not cleanly unmounted!  You should e2fsck.  Modifying 
> an
> unclean filesystem could cause severe corruption.
> Ignore/Cancel? i

Eeek.  You shouldn't do that.

> No Implementation: This ext2 filesystem has a rather strange layout!  Parted
> can't resize this (yet).

You are lucky that Parted doesn't support this.

> Is this something to do with the filesystem not being unmounted correctly? 
> I tried to use e2fsck, but it strongly warned against using it on a mounted 
> filesystem (i.e. my redhat 9 partition). Can you tell me how to get it 
> working? Thanks,

Sounds like you need to unmount first!  Is this your root file system?
If it is, you need to use a bootdisk.  However, Parted can't deal with
this file system anyway ("strange layout") :/


reply via email to

[Prev in Thread] Current Thread [Next in Thread]