[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 13 hour run with no change afterwards

From: Andrew
Subject: Re: 13 hour run with no change afterwards
Date: Sat, 09 Apr 2005 11:33:54 +1000

Don't bother.
I tried it with a friends PM8.0 temporarily installed
PM8.0 works fine (4 hours) - I guess parted doesn't resize big
Linux ext3 partitions (1 Gig RAM - so memory aint an issue)
PM8.0 does fine (on the same PC)
A pre old/post new comparison says they are the same also.

On Fri, 2005-04-08 at 16:14, Andrew wrote:
> Hi,
> I've got an older 200G HDD and just bought a 250G HDD
> Both are the same brand (WD) and report exactly the
> same geometry other than cylinders.
> I directly copied the 200G to the 250G (~5hrs)
> (equivalent of a file copy of /dev/hdc to /dev/hdf)
> Next I rebooted to remove the /dev/hdc drive 
> The new partition looks OK and works OK read-only.
> I ran parted on the console.
> Below is a recreation (with GPL removed) but is exactly the same anyway.
> It took about 13 hours to run and showed NO progress info at all
> (is there some way to get progress???)
> Basically I wanted to resize to '250G' less 1024Mb
> Parted didn't display any messages about the end value I entered.
> address@hidden ~]# parted /dev/hdf
> GNU Parted 1.6.15
> Using /dev/hdf
> (parted) print
> Disk geometry for /dev/hdf: 0.000-238475.179 megabytes
> Disk label type: msdos
> Minor    Start       End     Type      Filesystem  Flags
> 1          0.031 190779.719  primary   ext3        boot
> (parted) resize 1
> Start?  [0.0308]?
> End?  [190779.7188]? 237451
> (parted) quit
> Now when I check the drive it looks exactly the same - still
> with exactly the same partition table (even after a reboot)
> Any idea what happened for 13 hours?
> The HDD light was full on running the whole time.
> I then ran it a 2nd time as:
> 'date ; parted /dev/hdf resize 1 0.031 237451 ; date'
> And this time it took only 1 hour but still a
> 'parted /dev/hdf print' shows it unchanged.
> (OS is FC3)
> I've done this once before and had the same result about a year
> or so ago but not sure if the target was 200G or 250G and the
> source was probably an 80G
> I did eventually get it resized using parted last time, but not
> sure if I had to run it a few times or what happened.
> Anyone got any idea what's happening?
> Could it be a result of the raw copy?
> -Thanks for any help
> -Andrew

reply via email to

[Prev in Thread] Current Thread [Next in Thread]