[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-tar] Tar hangs (blocks?) on existing file when extracting with `--s

From: Dawid
Subject: [Bug-tar] Tar hangs (blocks?) on existing file when extracting with `--skip-old-files` and `--xattrs`.
Date: Thu, 6 Oct 2016 12:47:26 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.3.0


I've tried to use `tar + ssh + tar` pipeline to copy files between two hosts. The only twist over many examples you can find with 2 minutes of online searching is that I need to copy `xattrs` and not overwrite the existing files.

To my surprise it worked the first time, but on subsequent attempts it just hangs. After some investigation, it turned out that if one uses `--xattrs --skip-old-files` together, and `tar x ...` encouter existing file, it just hangs.

More investigation (when looking for workaround) revealed that `--keep-old-files` does not seem to preserve `xattrs` of the destination. The original destination file will be kept, but the xattrs will be overwritten anyway.

I've tested with tar 1.27.1 on Ubuntu 14.04.1, and please excuse me if there's not that much details given, but I'm in the middle of something, so I'm just shooting a quick email so I won't forget.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]