[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-tar] Tar hangs (blocks?) on existing file when extracting with

From: Pavel Raiskup
Subject: Re: [Bug-tar] Tar hangs (blocks?) on existing file when extracting with `--skip-old-files` and `--xattrs`.
Date: Fri, 07 Oct 2016 12:14:41 +0200
User-agent: KMail/5.3.1 (Linux/4.7.5-200.fc24.x86_64; KDE/5.26.0; x86_64; ; )

Hi Dawid, thanks for reporting this!

On Thursday, October 6, 2016 12:47:26 PM CEST Dawid wrote:
> I've tried to use `tar + ssh + tar` pipeline to copy files between two
> hosts. The only twist over many examples you can find with 2 minutes of
> online searching is that I need to copy `xattrs` and not overwrite the
> existing files.
> To my surprise it worked the first time, but on subsequent attempts it
> just hangs. After some investigation, it turned out that if one uses
> `--xattrs --skip-old-files` together, and `tar x ...` encouter existing
> file, it just hangs.

That's bug.  The set_xattr() function ignores RECOVER_SKIP.

> More investigation (when looking for workaround) revealed that
> `--keep-old-files` does not seem to preserve `xattrs` of the destination. The
> original destination file will be kept, but the xattrs will be overwritten
> anyway.

This is related bug too, can you please try the attached patch?


Attachment: 0001-xattrs-don-t-set-xattrs-when-skip-old-files-is-used.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]