[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Msys install and "\"

From: Matthew David Parker
Subject: Re: [Chicken-users] Msys install and "\"
Date: Mon, 11 Dec 2006 09:00:27 -0500 (EST)

Well, I actually just wrote that wrong, it's installed to /usr/local/bin

The reason why I don't want it in C:\program files\chicken is because I
have everything else I need for my project installed in msys, such as SDL
and all its varients.

The autoconf setup in msys works very well, except for making the "\" when
it should be "/".  Shouldn't there be some way to change this in the
configure script?


On Sat, 9 Dec 2006, Brandon J. Van Every wrote:

> Matthew David Parker wrote:
> > I'm trying to install chicken-2.5 on windows in MSYS.
> >
> > I tried using cmakeSetup to make MSYS makefiles, and then I compiled them
> > from within MSYS by typing "make" and "make install".  I had it install
> > to /bin within msys.  For some reason, the binaries don't seem to read any
> > command-line arguments.
> Bad idea to use /bin or /usr/bin as they're reserved for binaries linked
> with the MSYS runtime.  Please try /usr/local/bin instead.  I don't know
> that it'll solve your problem, but it's worth a try.
> I typically install to E:\Program Files\Chicken .  Then I typically use
> a Windows Command Prompt, not a MSYS shell.  So it's possible that we've
> missed something.  You can certainly put E:\Program Files\Chicken in
> your Windows PATH, before you even start MSYS.  I don't know, however,
> if there are general problems of operation under MSYS.
> > For instance, I try:
> >
> > $ csc
> > csc: no source files specified
> >
> > The commands work ok if I run them in the regular windows terminal, but I
> > want to run them in MSYS so that I can use all my other libraries I've
> > installed in MSYS.
> >
> > So, I tried compiling chicken using the regular ./configure script.  That
> > compiled ok, and these binaries can read the command-line arguments, so
> > they are almost exactly what I want.  However, for some reason chicken
> > uses a "\" instead of a "/" for the last slash when it runs some other
> > chicken command.
> >
> > Like, if I run csc on a test file, it will try to run chicken, but it will
> > try to run the command:
> >
> > /usr/local/bin\chicken
> >
> > Which it cannot find, so it fails.  Is there some way I can get chicken to
> > do a "/" instead?
> >
> It's probably in the sources and it's probably not smart enough about
> compilers vs. shells.  The shell we built with, definitely doesn't have
> to be the same as the shell we're currently using.
> Cheers,
> Brandon Van Every
> _______________________________________________
> Chicken-users mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]