[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Add "riscv" as an alias for "riscv32"

From: Palmer Dabbelt
Subject: Re: [PATCH] Add "riscv" as an alias for "riscv32"
Date: Wed, 20 Jun 2018 16:55:57 -0700 (PDT)

I don't really disagree with you here, as the original rationale for naming the tuples "riscv32-*" and "riscv64-*" was to avoid leaving anything ambiguous. Unfortunately the internet is full of people with strong opinions on these sorts of things, and some members of the RISC-V community have strong enough opinions that the tuples should be named "riscv-*" that they've gone and patched the toolchain sources to accept these names and then distributed binaries with the non-standard names.

I've actually gone to pretty long lengths to avoid sending this patch, but it's been a year since I first attempted to get people to stop wasting time with non-standard tuple names and nothing has changed. I finally caved and submitted this patch so we could at least contain the name at config.sub to avoid it ending up in everyone's build scripts.

So I'm in the odd situation of submitting a patch I actually disagree with :).

The one saving grace here is that most of the RISC-V toolchains support generating code for all targets -- in other words "riscv32-*-gcc -march=rv64gc" is a valid thing to do, and will generate 64-bit code (and links against a 64-bit libc). As a result, none of this actually matters.

On Wed, 20 Jun 2018 14:40:01 PDT (-0700), address@hidden wrote:
Why does a user who doesn't know what *bitwidth* they want pass an
explicit config anyways? IMO it's a shame legacy ones need have both
explicit and implicit variants on so many axes---one has to know the
fully history to tell what's going on which might be fine for greybeards
but is hostile to new programmers. The required bitwidth for new arches
like wasm and riscv restores the symmetry, and so is pleasing to the
eye, clearer to the beginner, and simpler for the implementation. I am
strongly against this change.


On 06/20/18 13:24, Palmer Dabbelt wrote:
Most RISC-V toolchains can generate code for all RISC-V targets, but are
currently named "riscv32-*" and "riscv64-*".  Users have suggested that
these names are unintuiative and would like tuples to be "riscv-*".

This patch enables "riscv-*" tuples by adding a config.sub rule that
replaces "riscv-*" with "riscv32-*".  The first ISA described by the
RISC-V specification is RV32I, a 32-bit ISA, so making "riscv-*" mean
32-bit seems like the sane way to go.  There are also handful of tests
added, which all pass for me.

This has been discussed on various mailing lists a half dozen times, but
I never got around to submitting a patch

reply via email to

[Prev in Thread] Current Thread [Next in Thread]