[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Add "riscv" as an alias for "riscv32"

From: Liviu Ionescu
Subject: Re: [PATCH] Add "riscv" as an alias for "riscv32"
Date: Fri, 22 Jun 2018 04:40:56 +0300

> On 22 Jun 2018, at 04:17, DJ Delorie <address@hidden> wrote:
> If by this patch you mean that "riscv-unknown-linux-gnu" means EITHER
> riscv32 (when on a 32-bit os) OR riscv64 (when on a 64-bit os), then I
> would prefer *against* this

The whole discussion is relevant only to cross toolchains intended to generate 
code for embedded devices, where the -march/-mabi is and must be always given 
explicitly, there is no need to guess anything, and the shorter prefix `riscv-` 
reduces confusion.

Native toolchains should probably retain the explicit bitsize in the prefix, as 
they do now.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]