[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Demexp-dev] DemExp 0.4 compilation issue with CDuce 0.3.9

From: Thomas Petazzoni
Subject: Re: [Demexp-dev] DemExp 0.4 compilation issue with CDuce 0.3.9
Date: Thu, 14 Jul 2005 20:01:21 +0200
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050602)


[ Sorry for breaking the thread, but my last e-mail didn't reach yet the
demexp-dev mailing-list, for some reason. Maybe because the server is slow ]

Thomas Petazzoni a écrit :

> I traced down the issue a bit further, and I come to the conclusion that
> cdo2ml doesn't work the way it worked, or it is buggy. Trying to
> manually run cdo2ml doesn't work (it waits forever). Running it with
> strace gives interesting stuff :

As I said in the other e-mail, the problem was that the preprocessor to
use is "cduce --mlstub" instead of "cdo2ml --static".

However, running "cduce --mlstub" doesn't work, because it looks for
cdo2ml in the current directory. I have found a simple work around:
using -pp "/usr/bin/cduce --mlstub".

I've debugged the thing a bit, and came to the conclusion that when
"cduce" is run directly (assuming it's in the PATH), then Sys.argv.(0)
doesn't return the full path, and then "cdo2ml" path is incorrect.

The thing I don't understand is that when I run the ocaml interpreter
from the command line, and then invokes Sys.argv.(0), it correctly
displays the absolute filename :

address@hidden:~$ ocaml
        Objective Caml version 3.08.3

# Sys.argv.(0);;
- : string = "/usr/bin/ocaml"

Any idea of what's going on ?


PETAZZONI Thomas - address@hidden - Jabber: address@hidden
Fingerprint : 0BE1 4CF3 CEA4 AC9D CC6E  1624 F653 CB30 98D3 F7A7

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]