[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] error

From: Job de Haas
Subject: Re: [Discuss-gnuradio] error
Date: Mon, 10 Jan 2005 21:39:31 +0100
User-agent: Mutt/1.5.6+20040907i


I'm running a sarge system and just tried the tarballs from the site.
For me the compile and make check worked fine with just the debian
packages installed for all the required software.

Without trying to turn this into a debian list:

> I have debian testing (sarge) installed which has both gcc-3.3 and
> gcc-3.4
> test_all fails with both for different reasons (gcc-3.3 Bus Error,
> gcc-3.4
> Segmentation fault).
> I have a gnuradio cvs version from a while back which was compiled
> with the
> default gcc (gcc-3.3)
> >gcc --version
> >gcc (GCC) 3.3.4 (Debian 1:3.3.4-13)

For me gcc gives:

> gcc --version
gcc (GCC) 3.3.5 (Debian 1:3.3.5-5)

Is your debian system up to date? Do:

apt-get update
apt-get upgrade
apt-get dist-upgrade

and try again?

Related packages I have installed:

ii  autoconf       2.59a-2
ii  automake1.4    1.4-p6-8
ii  autotools-dev  20041130.2
ii  libtool        1.5.6-3
ii  swig           1.3.22-5
ii  libswig1.3.22  1.3.22-5
ii  pkg-config     0.15.0-4
ii  fftw3          3.0.1-11
ii  fftw3-dev      3.0.1-11
ii  python2.3      2.3.4-18
ii  python2.3-dev  2.3.4-18
ii  libboost-dev   1.31.0-9
ii  libboost-pytho 1.31.0-9
ii  tetex-base     2.0.2c-3
ii  tetex-bin      2.0.2-25
ii  gcc            3.3.5-1
ii  gcc-3.3        3.3.5-5
ii  gcc-3.3-base   3.3.5-5
ii  libgcc1        3.4.3-6
ii  g++            3.3.5-1
ii  g++-3.3        3.3.5-5
ii  libstdc++5     3.3.5-5
ii  libstdc++5-3.3 3.3.5-5

There are a load more python packages, but this is most relevant I

I verified fftw3 for debian sarge is compiled with:

./configure --prefix=/usr --enable-single --enable-shared
  --enable-threads --enable-k7 --enable-sse

And as I said make check finished properly on a system with a Pentium
mobile chip model name      : Intel(R) Pentium(R) M processor 1700MHz

I haven't run anything yet with gnuradio and I'm not sure why it works
with gcc 3.3. My guess is Debian patched gcc 3.3 for this bug.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]