[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] No module name gnuradio

From: w_esco_m
Subject: Re: [Discuss-gnuradio] No module name gnuradio
Date: Sat, 29 Oct 2005 11:46:23 -0700

Dear Eric:

As usual, Eric, you are extremely kind and helpful; thank you. You give me inspiration to push on!

At 10:48 PM 10/26/2005, you wrote:
On Wed, Oct 26, 2005 at 08:23:55PM -0700, address@hidden wrote:
>  No one said which desktop to take,
> so I picked kde.

Good choice.   It's one of the two distributions I use every day.
FWIW I also use KDE.

Glad to know that KDE is OK!

With Mandrake 10.1, I believe that there are only *three* things that
didn't come with the distribution that you would have needed to build.
Even fewer with SuSE 9.3 Pro.

These would have been cppunit, FFTW and SDCC.

Actually, I bought the Mandrake 10.1 official CDs from imageindustries on Ebay. As you know from my previous post where you helped me, I had to update automake, too, since mine was 1.4-p6 and yours was 1.8.5. This was the reason for many compile failures.

> As an example of the various problems, fftw did not compile at the beginning, but after
> several tries and stopping the use of "make distclean", I got it to
> compile.

The README in gnuradio-core contains the magic required for FFTW, e.g.,

    (2)  FFTW 3.0 or later            http://www.fftw.org

    IMPORTANT!!!  When building FFTW, you MUST use the --enable-single and
    --enable-shared configure options.  This builds the single precision
    floating point version which we use.  You should also use either the
    --enable-3dnow or --enable-sse options if you're on an Athlon or Pentium

I was using these configure options from the beginning, but since my machine is an Athlon, I had to use a different switch (enable-k7) instead of enable-sse. This was not hard to figure out.

FYI, I just confirmed that fftw-3.0.1.tar.gz builds perfectly out of the box.

  ./configure --enable-single --enable-shared --enable-sse
  make install

Out of curiosity, where did you ever get the idea that "make
distclean" was a good idea?

To answer your question: in frustration with the failed attempts, I tried "make distclean" because it was listed in the README text from fftw:

Quoting from http://www.fftw.org/fftw3_doc/Installation-on-Unix.html#Installation-on-Unix

"Section 8.1:

This will build the uniprocessor complex and real transform libraries along with the test programs. (We recommend that you use GNU make if it is available; on some systems it is called gmake.) The "make install" command installs the fftw and rfftw libraries in standard places, and typically requires root privileges (unless you specify a different install directory with the --prefix flag to configure). You can also type "make check" to put the FFTW test programs through their paces. If you have problems during configuration or compilation, you may want to run "make distclean" before trying again; this ensures that you don't have any stale files left over from previous compilation attempts."

Sounded good to me; but as usual, there is only one way to do it right; many ways to screw up!

Not true.  Having /usr/local/bin in your PATH goes a long way.

Duh - should have known this.

Also not true.  I'm using whatever came with Mandrake 10.1 and
SuSE 9.3.  A quick check shows that Mandrake 10.1 ships with 1.8.5 and 1.4.

See above. Not with the Mandrake I got; perhaps buying CDs from the web was my error.

Have you tried Mandrake's graphical "Software Management" tool?

One issue is that Mandrake is really no more anyway. If you get "Mandrake 10.1 Official" CDs like I did, you cannot update them unless you pay a fee to get upgrades from the new company, now called Mandriva. Because I wanted security fixes, I did pay the fee for the update service. However, the automatic Mandrake software updates fail because these update programs point to the wrong URLs. I fixed this on my own by finding a new rpm for the "rpmdrake" program, which gave me access to the proper update site for patches to the OS. I would suggest that you recommend to people to really buy "Mandriva 2006" or some specific shrink-wrapped version to prevent this kind of problem.

After this fixup of the URL for updates, the Software Management tool works.

Thanks for all of your input.  And again, sorry to hear about your
frustration.  With some luck and effort I think we can address most of
your concerns.

I very much appreciate your patience!

Best, Weo WN6I

reply via email to

[Prev in Thread] Current Thread [Next in Thread]