[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] No module name gnuradio

From: Robitaille, Michael
Subject: Re: [Discuss-gnuradio] No module name gnuradio
Date: Fri, 28 Oct 2005 10:01:42 -0600

Finally got GNU Radio compiled and working with the USRP so I am out of the
wood for now.


I installed it in the 'standard' location, unfortunately I could do that
only as the root and I can only run GnuRadio as root.  I can't even use
'sudo' to run usrp_oscope.py.


Not sure if I should move this to another subject, let me know Eric.


Here is what I did and the difficulties that I still having.


I made a group and changed the /usr/local directories per Eric's


Eric wrote:
> > Depends on your setup.  I don't install with sudo (being generally
> > paranoid), and have arranged things so that I'm in a group that has
> > write access to everything under /usr/local.  Judicious use of 
> >  chmod g+s on directories under there is useful.
> Shell programming 101:  
>  $ find /usr/local/ -type d -print0 | xargs -0 chgrp <some-group-you-like>
>  $ find /usr/local/ -type d -print0 | xargs -0 chmod g+rwxs
> Figuring out what the setgid bit on a directory does is left as an
exercise ;)


Sid not - exercise;

Per my old Unix book;

Unless the set group ID (sgid) permission of an executable file are set, the
process created is assigned your uid and gid at its real and effective uid
and real and effective gid, respectively. File access for a process is
determined by its effective uid and effective gid.


After making the changes to /usr/local based on my new group, I tried to
build the base line software needed and got the following type of error
while making sdcc:

make -C `dirname hc08/port.a`

make[2]: Entering directory `/opt/GnuRadio/sdcc/src/hc08'

make[2]: Nothing to be done for `all'.

make[2]: Leaving directory `/opt/GnuRadio/sdcc/src/hc08'

/usr/bin/install -c -d /usr/local/bin

/usr/bin/install: cannot change permissions of `/usr/local/bin': Operation
not permitted

make[1]: *** [installdirs] Error 1

make[1]: Leaving directory `/opt/GnuRadio/sdcc/src'


I appears' that the make is trying to change permission on /usr/local/bin. 


Making myself root solved this problem but now I can't run the gnuradio
software except as root.


Even when I use 'sudo' to run usrp_oscope.py, I get the error


ImportError: libwx_gtk2d_xrc-2.6.so.0: cannot open shared object file: No
such file or directory


The file is in the /urs/local/bin and my LD_LIBRARY_PATH is set to that
location.  I set the same environment variables for both my regular user and


If I don't use 'sudo' I get even more errors.  I think that they are related
to usb access. I try to use the fstab per another post and it did not seem
to help.




Michael A. Robitaille

Senior Engineer

Schafer Corporation

2309 Renard Place SE, Suite 300

Albuquerque, NM 87106

Phone: 505-338-2869

Fax: 505-242-9975


reply via email to

[Prev in Thread] Current Thread [Next in Thread]