[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] gr-audio-portaudio module vs portaudio-0.19

From: Berndt Josef Wulf
Subject: [Discuss-gnuradio] gr-audio-portaudio module vs portaudio-0.19
Date: Sat, 18 Mar 2006 12:09:02 +1030
User-agent: KMail/1.9.1


I'm trying to create a gr-audio-portaudio package for pkgsrc. Running 
gr-audio-portaudio's configure script will lead to the following error 

echo $ECHO_N "checking for portaudio >= 19... $ECHO_C" >&6
checking for portaudio >= 19... Package portaudio was not found in the 
pkg-config search path. Perhaps you should add the directory containing 
`portaudio.pc' to the PKG_CONFIG_PATH environment variable No package 
'portaudio' found
configure: error: Library requirements (portaudio >= 19) not met; consider 
adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a 
nonstandard prefix so pkg-config can find them.

The configure script uses pkg-config to find details about portaudio. However, 
portaudio-0.19cvs doesn't provide a portaudio.pc file. My guess is that 
portaudio.pc comes as part of the portaudio RPM package, possibly created 
manually by the package maintainers - please correct me if this ins't the 

With this in mind, wouldn't it be better to check for the release version 
using the portaudio function Pa_GetVersion() function?

cheerio Berndt

Attachment: pgpVkcCBeSYWn.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]