[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] running

From: David Caruth
Subject: [Discuss-gnuradio] running
Date: Sun, 14 May 2006 17:19:08 -0700 (PDT)

I've just started playing with GnuRadio and the USRP, and was hoping to run it on Windows XP.  I found Martin's installer "setup-gnuradio-complete-2.6cvs.exe" and it worked great.  I then tried to run the example to listen to some radio (I had this running with a fedora core 5 linux installation with the same usrp).  I received the following error messages:
C:\caruthd\usrp\gnuradio-examples-0.7\python\usrp>python usrp_wfm_rcv.py -f 101.1
found 5 busses
Using RX d'board A: TV Rx
>>> gr_fir_ccf: using SSE
>>> gr_fir_fff: using SSE
Traceback (most recent call last):
  File "usrp_wfm_rcv.py", line 268, in ?
    app = stdgui.stdapp (wfm_rx_graph, "USRP WFM RX")
  File "C:\Python24\Lib\site-packages\gnuradio\wxgui\stdgui.py", line 36, in __
    wx.App.__init__ (self, redirect=False)
  File "C:\Python24\Lib\site-packages\wx-2.6-msw-ansi\wx\_core.py", line 7700,
in __init__
  File "C:\Python24\Lib\site-packages\wx-2.6-msw-ansi\wx\_core.py", line 7352,
in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "C:\Python24\Lib\site-packages\gnuradio\wxgui\stdgui.py", line 39, in On
    frame = stdframe (self.flow_graph_maker, self.title, self._nstatus)
  File "C:\Python24\Lib\site-packages\gnuradio\wxgui\stdgui.py", line 60, in __
    self.panel = stdpanel (self, self, flow_graph_maker)
  File "C:\Python24\Lib\site-packages\gnuradio\wxgui\stdgui.py", line 81, in __
    self.fg = flow_graph_maker (frame, self, vbox, sys.argv)
  File "usrp_wfm_rcv.py", line 93, in __init__
    False)  # ok_to_block
  File "C:\Python24\Lib\site-packages\gnuradio\audio_windows.py", line 213, in
    return _audio_windows.sink(*args)
NotImplementedError: No matching function for overloaded 'sink'
I had seen a previous post where Eric replied that a hex string needed to be replaced by a gr function with the hex string as an argument, but from looking through the .py files called here, i did not see anything obvious.  has anyone else had this problem?  thanks in advance for any help!  oh, and by the way, "usrp_fft.py" ran without a problem.
Thanks a lot!

Get amazing travel prices for air and hotel in one click on Yahoo! FareChase
reply via email to

[Prev in Thread] Current Thread [Next in Thread]