[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Mode S and ADS-B

From: Tom Owens
Subject: Re: [Discuss-gnuradio] Mode S and ADS-B
Date: Fri, 31 Aug 2007 09:37:25 -0400
User-agent: Thunderbird (X11/20070728)

Eric A. Cottrell wrote:
Tom O wrote:
Hi Eric,

When I run usrp_mode_s_logfile.py I get:
   ImportError: cannot import name air

Can you help me out?


air is the name of the python library that contains the gr-air blocks. Make sure you compiled and installed gnuradio properly and have
PYTHONPATH set correctly.
There should be several _air.* and air.* files in site-packages/gnuradio
(typically /usr/lib/python<version>/site-packages/gnuradio or
/usr/local/lib/python<version>/site-packages/gnuradio).  The default
prefix for compile is /usr/local so you may have to add subdirectories
under the /usr/local directory to various paths.

73 Eric

Thanks Eric,
I see what you are saying. What I ended up doing to correct the error is svn'd your version of gnuradio: svn co http://gnuradio.org/svn/gnuradio/branches/developers/wb1hbu/wip/ gnuradio.1
then: ./bootstrap, ./configure, make, make check, make install.
What does it take to keep a stable release of gnuradio and only add your piece of gr-air and have it all compile and install correctly?

Now when I run usrp_mode_s_logfile.py I get:

Traceback (most recent call last):
 File "./usrp_mode_s_logfile.py", line 3, in ?
   from gnuradio import gr, gru, usrp, optfir, eng_notation, blks, air
File "/usr/local/lib/python2.4/site-packages/gnuradio/gr/__init__.py", line 27, in ?
   from gnuradio_swig_python import *
File "/usr/local/lib/python2.4/site-packages/gnuradio/gr/gnuradio_swig_python.py", line 23, in ?
   from gnuradio_swig_py_runtime import *
File "/usr/local/lib/python2.4/site-packages/gnuradio/gr/gnuradio_swig_py_runtime.py", line 6, in ?
   import _gnuradio_swig_py_runtime
ImportError: libgromnithread.so: cannot open shared object file: No such file or directory

When I run a find on libgromnithread.so I get:

I did see a make check error that showed error on check_TESTS /gnuradio.1/gnuradio-core/src/python/gnuradio/gr, check_am, and check_recursive

Thanks for your help,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]