[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Big bugs out of nowhere...

From: George Nychis
Subject: Re: [Discuss-gnuradio] Big bugs out of nowhere...
Date: Mon, 17 Mar 2008 12:41:36 -0400
User-agent: Thunderbird (X11/20071008)

Have you changed anything on the USB bus? For example, adding another device that is USB intensive or adding a hub? I received this error once and narrowed it down to my webcam on the same bus sucking up bandwidth, causing the USRP to have a hard time initializing. Once I disconnected the webcam, it went away.

- George

Eric Blossom wrote:
On Mon, Mar 17, 2008 at 05:50:03AM -0400, Jared Jensen wrote:

Yes.  I double checked just to make sure.  I have a usrp group.  I'm
in it.  My 10-usrp.rules file is verbatim from the site.  In the
past, I had no trouble accessing the usrp as non-root... but I
triple-checked, and the group is setup correctly.

Let me ask the question a different way.

If you run as root, does it work?


I restarted, and I still get the same behavior.

Date: Fri, 14 Mar 2008 10:54:42 -0700
From: address@hidden
To: address@hidden
CC: address@hidden
Subject: Re: [Discuss-gnuradio] Big bugs out of nowhere...

On Fri, Mar 14, 2008 at 10:48:29AM -0400, Jared Jensen wrote:
I haven't been using my usrp for a little while.  I've been porting
my code to a TI C64x+.  I came back to my usrp today and tried to
run just a basic receive for test data for my TI DSP.  I got the
following error.  In usbview I see a "USRP Rev4" under my ehci
controller.  I thought it might be the board, so I grabbed my other
usrp, and the exact same thing happened.  (This is with
gnuradio-3.1.1 ) So I tried my older gnuradio install, and tried to
run usrp_fft.py... and the same things happened.  I checked
/usr/local/share/usrp.  It has all of the rbf (see below).  Has
anyone encountered this before?  It was just a few months back
everything was great... I didn't touch gr for a while... came back
and BOOM.  :( No joy.

Have you followed the instructions for ensuring that you can access
the USRP w/o being root?



usb_control_msg failed: error sending control message: Protocol error
usb_control_msg failed: error sending control message: Protocol error
usb_control_msg failed: error sending control message: Protocol error
usrp: failed to load fpga bitstream 

  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp1.py", line 1232, 
in source_c
    return _usrp1.source_c(*args)
RuntimeError: can't open usrp1

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]