[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with Installation of GNU radio

From: Don Ward
Subject: Re: [Discuss-gnuradio] Problem with Installation of GNU radio
Date: Mon, 19 May 2008 13:44:39 -0400

Hi Prasanna,

      I tried installing GNU radio in windows using cygwin. I did it as it
was given on the gnuradio.org website.
 I initially built a minimal GNU radio system, with just omnithread,
gnuradio-core and gr-audio-oss modules enabled and it worked fine. Then I
when I tried to build a full GNU radio system, it gave me the following
error in the usrp module-

     mkdir -p html
    xmlto html-nochunks ../../usrp/doc/usrp_guide.xml
    xmlto: input does not validate <status 1>
http://www.oasis-open.org/docbook/xml/4.2/1:parser error : Content error in
the external subset
<! DOCTYPE html

I have not been able to make xmlto work with the GNU Radio xml files on Cygwin. Since this is just the documentation that is failing, you can build GNU Radio without it. One way is to get rid of xmlto (uninstall it with Cygwin setup, remove it from /usr/bin, or rename it), then rerun configure and try it again. Another solution is to edit usrp/doc/Makefile to remove usrp_guide.html from the DOCBOOK_HTML_FILES line, but you will need to do this every time you run configure. The best solution (aside from making xmlto work) would be to figure out how to tell configure to ignore xmlto.

If anyone knows why xmlto doesn't work (on Cygwin), please let us know.

-- Don W.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]