[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] First-timer Question

From: Mr. mollasadra
Subject: [Discuss-gnuradio] First-timer Question
Date: Wed, 21 May 2008 21:00:22 +0000

Since my last question (which was on installing GNU Radio on VM-ware) I have abandoned that approach and now am trying it out on an actual machine.
I apologize in advance if this question seems too long, I'm just going to walk through everything I did to get to where I am now
(so in the process it might even turn out to be a resource for other first-timers who are having problems)
I'm using fedora 8 (and through out this the USRP board is not plugged in).

So after going through a brand new Fedora 8 installation, to get a working GNU Radio I first did this:
$ yum isntall gnuradio

since I wasn't sure what exactly had happened, I kind of disregarded it and continued with this path:

did this:
$ yum install sdcc

then did these:
$ yum groupinstall "Engineering and Scientific" "Development Tools"
$ yum install fftw-devel cppunit-devel wxPython-devel libusb-devel guile boost-devel alsa-lib-devel numpy

then added these two manually to "/home/[user]/.bashrc":


then  I restart the computer for the changes to take effect
then I finish it off by doing theses:

$ svn co http://gnuradio.org/svn/gnuradio/branches/releases/3.1 gnuradio
$ cd gnuradio
$ ./bootstrap
$ ./configure
$ make
$ make check
$ sudo make install

all the installation worked as it should.
BTW: after the ./configure I get this (which seems normal):

The following components were skipped either because you asked not
to build them or they didn't pass configuration checks:


Now for a test I ran this:
$ cd /gnuradio-examples/python/audio/
$ python dial_tone.py

Which gives me this error:

    audio_alsa_sink[hw:0,0]: set_period_time_near failed: Invalid argument
    Traceback (most recent call last):
      File "dial_tone.py", line 55, in <module>
      File "dial_tone.py", line 48, in __init__
        dst = audio.sink (sample_rate, options.audio_output)
      File "/usr/lib/python2.5/site-packages/gnuradio/audio_alsa.py", line 236, in sink
        return _audio_alsa.sink(*args)
    RuntimeError: audio_alsa_sink

I had seen this error before and the cause of it (as I had found on theses forums) was another program (youtube's video player in browser)
using up the sound device. so by closing down FireFox it worked, but now it makes no difference. I know my sound device works (as I was able to play a song fine)
but I'm getting really frustrated (due to the non-ending steps just to get GNU Radio running and to some degree my lack of fully understanding the linux architecture). Any help would be appreciated.

My next question would be (if I managed to somehow resolve the prev. problem) to actually hook up the USRP to the machine, what steps do I have to take to ensure the software can communicate with the hardware? I found this page:

but does this page still exist somewhere on this website (hopefully with updated info.) or if it does not, why not?

Thanks you all.

Keep your kids safer online with Windows Live Family Safety. Help protect your kids.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]