[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: [Discuss-gnuradio] Big bugs out of nowhere...

From: Eric Blossom
Subject: Re: Fwd: [Discuss-gnuradio] Big bugs out of nowhere...
Date: Sat, 20 Dec 2008 14:02:35 -0800
User-agent: Mutt/1.5.18 (2008-05-17)

On Sat, Dec 20, 2008 at 06:38:45PM -0300, Igor Almeida wrote:
> Hi Johnathan,
> Thank you for the insight. I was indeed NOT a user of the usrp group
> to which udev was configuring the block device.
> The thing is, we have an LDAP-configured network here, and we use it
> to fetch a number of configs, including groups, passwords and whatnot.
> Bottom line, there were two 'usrp' groups: one from /etc/group, with
> no members; and the other was from LDAP, with myself as member.
> So I removed the usrp group from /etc/group{,-}, and it no longer
> exists acording to 'getent group|grep usrp', but now udev seems to be
> confused as it changes the permissions correctly, but the group
> association is not performed:
> /dev/bus/usb/007:
> total 0
> crw-rw-r-- 1 root root 189, 768 2008-12-19 06:38 001
> crw-rw---- 1 root root 189, 769 2008-12-19 09:50 002
> Notice the crw-rw---- block, which showed up when I plugged the usb cable.
> So if udev cannot be aware of the usrp group fetched from LDAP, the
> whole LDAP-centralizing-access-permissions scheme goes down, because I
> will have to manually create and maintain/synchronize the usrp group
> in every machine on the lab.

Have you looked at any of the system log files? Usually /var/log/*
They'll probably tell you what's going on.

There may also be a way to increase the level of debug output from udev. 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]