[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] USRP2 missing Quadrature samples

From: Matt Ettus
Subject: Re: [Discuss-gnuradio] USRP2 missing Quadrature samples
Date: Thu, 05 Feb 2009 09:51:26 -0800
User-agent: Thunderbird (X11/20090105)


Are you using the latest svn version on the host computer as well? Have you modified any files?


Leslie Choong wrote:
Thanks to Johnathan's help it seems my problem is with the USRP2's
recognition of the daughterboard. I used a USRP1 Rev 4.1 to flash my
FLEX 2400 to the rfx2400 EEPROM using this command:
./burn-db-eeprom -A -t rfx2400 --force

Which worked fine:

Then I plugged in the board into my USRP2 and still receive this
output when I run:
./usrp2_rx_cfile.py -f 2.425G -N 1M -v outusrp2

usrp2: failed to enable realtime scheduling
Using mid-point gain of 0.0 ( 0.0 - 0.0 )
Network interface: eth0
USRP2 address: 00:50:c2:85:30:37
Using RX d'board id 0x0001
Rx gain: 0.0
Rx baseband frequency: 0
Rx DDC frequency: -25M
Rx residual frequency: 0
Rx decimation rate: 16
Rx sample rate: 6.25M
Receving 1M samples
Writing 32-bit complex floats
Output filename: outusrp2

This is the same output as before. I can use this daughterboard with
the USRP1 with no problem. Using the USRP1 with usrp_rx_cfile.py:
Using RX d'board A: Flex 2400 Rx

So it seems like the USRP2 is having problems identifying the
daughterboard properly. I found a thread that discusses this, but
found no resolution:

Any insight as to why this is happening with the USRP2? This is with
the latest firmware and FPGA image. Perhaps some hardware jumpers?
Thanks once again for the help!

On Wed, Feb 4, 2009 at 6:32 PM, Johnathan Corgan
<address@hidden> wrote:
On Wed, Feb 4, 2009 at 6:11 PM, Leslie Choong <address@hidden> wrote:

Hi Jonathan, I've followed those instructions and attached the output files.
The stdout has been pasted here for the 3 commands:
Your RFX2400 is identifying itself as a BasicRX:

Using RX d'board id 0x0001
This is causing the USRP2 firmware and host code use the wrong set of
daughterboard routines to deal with it.  It explains your symptoms

The daughterboard ID is stored in an EEPROM on the board.  Either
yours was misprogrammed or became corrupted.  Either way, there isn't
yet a method with the USRP2 to program this outside the factory.  If
you have a USRP1 available, you can put the RFX2400 into that and
update the EEPROM that way.  Until then, you won't get any valid
sample data from the card.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]