[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] OpenBTS compilation error

From: T. W.
Subject: [Discuss-gnuradio] OpenBTS compilation error
Date: Wed, 25 Feb 2009 21:00:13 +0100

First I got the openBTS code from gnuradio site (svn co
http://gnuradio.org/svn/openbts/trunk/ openbts).

Then I run the ./bootstrap and ./configure commands succesfully.

But the following errors occurred when I run make. ("xxxx" was used to
mask out my username on the machine.)  Can anyone shed some light on

I was using a 32-bit Ubuntu 8.10 desktop virtual machine on a 64-bit
Windows XP machine.


make[2]: Entering directory `/home/xxxx/openbts/openbts/Transceiver'
if /bin/bash ../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I.
-I. -I.
.  -I../CommonLibs -I../Control -I../GSM -I../SIP -I../TRXManager
nclude   -g -O2 -MT radioInterface.lo -MD -MP -MF
".deps/radioInterface.Tpo" -c
-o radioInterface.lo radioInterface.cpp; \
  then mv -f ".deps/radioInterface.Tpo" ".deps/radioInterface.Plo"; else
m -f ".deps/radioInterface.Tpo"; exit 1; fi
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../CommonLibs
 -I../GSM -I../SIP -I../TRXManager -I/usr/local/include -g -O2 -MT
e.lo -MD -MP -MF .deps/radioInterface.Tpo -c radioInterface.cpp  -fPIC
-DPIC -o
In file included from USRPDevice.h:25,
                 from radioInterface.h:25,
                 from radioInterface.cpp:23:
/usr/local/include/usrp_bytesex.h:37:2: warning: #warning Using
non-portable cod
e (likely wrong other than ILP32).
In file included from radioInterface.h:24,
                 from radioInterface.cpp:23:
sigProcLib.h:35: warning: ‘typedef’ was ignored in this declaration
sigProcLib.h:45: warning: ‘typedef’ was ignored in this declaration
In file included from radioInterface.h:25,
                 from radioInterface.cpp:23:
USRPDevice.h:42: error: ‘usrp_standard_rx_sptr’ does not name a type
USRPDevice.h:43: error: ‘usrp_standard_tx_sptr’ does not name a type
make[2]: *** [radioInterface.lo] Error 1
make[2]: Leaving directory `/home/xxxx/openbts/openbts/Transceiver'
Posted via http://www.ruby-forum.com/.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]