[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] usb connection USRP

From: Don Latham
Subject: [Discuss-gnuradio] usb connection USRP
Date: Fri, 24 Apr 2009 15:33:40 -0600 (MDT)
User-agent: SquirrelMail/1.4.17

OK. Finally managed to get the gnuradio compiled and installed. Now I've
put the recommended 10-usrp.rules file in the right place, checking the
syntax twice, and tried all the suggested steps (reboot, start/stop udev,
killall etc.). When I look at /dev/bus/usb, I see the "owners" of the
device as root root instead of root usrp. lsusb shows the device is there,
lsusb -v shows std.ihx has not loaded.
Further, running the datarate example <./usrp_benchmark_usb.py>, brings
the joyous news:
"could not claim interface operation not permitted" and the subsequent
failure to load std.ihx. I have made the usrp group and am happy to be a
member of same. The failure seems to be that the device belongs to root
root and not to root usrp? I tried to fix that, but of course failed
miserably, and none of the books I have here give me a clue as to the
arcane structure of usb interface software structure. I should mention
that unplugging and replugging the usb cable or restarting the usrp helps
at all. Oh woe. Can you help?
Thanks again!

Dr. Don Latham AJ7LL
Six Mile Systems LLP
17850 Six Mile Road
POB 134
Huson, MT, 59846
VOX 406-626-4304

reply via email to

[Prev in Thread] Current Thread [Next in Thread]