[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] USRP2 debugging procedure

From: Jeffrey Karrels
Subject: [Discuss-gnuradio] USRP2 debugging procedure
Date: Sat, 19 Dec 2009 07:57:53 -0800

Hello All.

I finally had the opportunity to upgrade to the USRP2.0. I received it
in the mail yesterday, and I am playing around with it right now. I
hate to ask the noob question here, but for the life of me, I cannot
get it running.

Problem Description: When powering the USRP2.0 (with the SD card in
place), none of the LEDs [A-F] light up. There is power, the rear fan
turns, and the onboard D201 LED is illuminated.

I tried reloading the SD card a couple of times with different
versions of both the S/W and FPGA bin files.

address@hidden firmware]# ./u2_flash_tool --dev=/dev/sdd -t s/w txrx.bin -w
address@hidden firmware]# ./u2_flash_tool --dev=/dev/sdd -t fpga u2_rev3.bin -w
address@hidden firmware]#./u2_flash_tool --dev=/dev/sdd -t s/w
txrx_edk10.1_r10766.bin -w
address@hidden firmware]# ./u2_flash_tool --dev=/dev/sdd -t fpga
u2_rev3_ise10.1sp3_r10766.bin -w


When those failed produce any activity, I also tried a new SD card
which ended with the same results. I cannot see it making a
difference, but I am running Fedora 12 with the latest trunk code. I
have tried compiling my own bins as well as downloading the ones from:

Does anyone have any suggestions?

Thanks everyone

reply via email to

[Prev in Thread] Current Thread [Next in Thread]