[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] u2_flash_tool : Can not find the command

From: Andy_Long
Subject: [Discuss-gnuradio] u2_flash_tool : Can not find the command
Date: Tue, 2 Mar 2010 12:43:19 -0800 (PST)


I have finished all the install setup of GNUradio (in Ubuntu 9.04 by using
DebianPackages)and test for dial_tone example which seems operating well.
One problem is that the SD card delivered is broken as mentioned on website
that I have to use another SD card and write firmware by myself.

Thus I have downloaded the txrx.bin and u2_rev3.bin files from
http://gnuradio.org/releases/usrp2-bin/trunk/ try to run the u2_flash_tool
to write the firmware and FPGA code.

However, after running the command sudo u2_flash_tool --dev=/dev/sdb -t s/w
usrp2/firmware/txrx.bin -w (SD card  mounted as /dev/sdb in my machine). 

The terminal shows: bash: u2_flash_tool :command not found

The previous advices from Johnathan is that

((((The command is correct, but you'll need to run it from the directory
that u2_flash_tool is in, and reference it with ./u2_flash_tool.  We
don't install this script on the path.

(from usrp2/firmware directory):

$ sudo ./u2_flash_tool --dev=/dev/sdb -t s/w txrx.bin -w

$ sudo ./u2_flash_tool --dev=/dev/sdb -t fpga u2_rev3.bin -w

For the above to work, you'll need to put the full path to wherever you
downloaded the .bin files.


But can any one tell me that where is the full directory name of
“usrp2/firmware”? Because I can not find this directory in my computer.

I only find the directory as website address:

Since I am the beginner user of Linux system, I do not know how to enter
this website address in terminal. So I just download u2_flash_tool file to
my computer fold and go to this fold directory to run the command
u2_flash_tool again. But I still get the same error:   bash: u2_flash_tool
:command not found

Thanks in advance,

View this message in context: 
Sent from the GnuRadio mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]