[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Install Issues (linker can't find -lboost_program

From: Mike Benonis
Subject: Re: [Discuss-gnuradio] Install Issues (linker can't find -lboost_program_options)
Date: Fri, 26 Mar 2010 20:45:30 -0400
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3

On 26-Mar-10 17:07, Eric Blossom wrote:

It may be that you have boost installed in more than one place.

Try using:

   $ ./configure --with-boost=/opt/boost_1_42_0   ...
   $ make&&  make check&&  sudo make install


I've done ./configure and specified the boost location as you suggested, to no avail. I've also tried with boost 1.37.0 (last known working version) and still get this error.

This happens pretty late in the make process, and I feel like boost gets compiled in/used a lot beforehand. So maybe this is more a case of a broken module or something rather than a systematic issue. It's also worth noting that ./configure reports that boost is in place and happy when it does the check.

It might be helpful to know exactly where ld is looking for the boost library when it tries to link it in. Could you shed some light on this, or suggest some reading for me to do? I feel like understanding the root of the problem is much more useful than a quick fix.



Best regards,

Mike Benonis

reply via email to

[Prev in Thread] Current Thread [Next in Thread]