[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] USRP2 unable to receive signal at RX-B

From: Cheaw Wen Guey
Subject: Re: [Discuss-gnuradio] USRP2 unable to receive signal at RX-B
Date: Wed, 8 Sep 2010 11:38:00 +0800 (MYT)
User-agent: SquirrelMail/1.4.16


I tried to run mg-gcc --help and the program is not added in properly. I
tried following step by step in the wiki and still no go.

Any ideas?

On 08/28/2010 10:38 AM, Cheaw Wen Guey wrote:
> Thanks Josh.
> Found that line of code.
> Following your advice, I have tried both methods you mentioned and have
> run into problems for both.
> For the first one, I have followed the install instructions for microblaze
> toolkit given on the gnuradio wiki and after setting the path, I tried to
> configure. usrp2-firwmare failed and the reason that wwas showned was that
> they failed to detect mb tools.

Try running mb-gcc from the command line first. See if you can do:
mb-gcc --help

Once that works, you run the commands (configure.gnu -- not configure --
weird I know...):

cd usrp2/firmware

Since you are building FPGA images (I assume you have a copy of ISE),
then you may just want to use the mb-gcc that comes with Xilinx EDK.

> I then tried to install UHD and I managed to copy the firmware and FPGA
> configuration into the card and I managed to verify by pinging the USRP2.


> I am however unable to run any of the cpp files even as root as permission
> is denied.

Why are you trying to execute c++ files?


> I am asking for help if there is anyone who has a modified binary firmware
> file compiled for the gnuradio version that I can have. I also would like
> to ask for help to compile a modified FPGA image.
> Thanks
>> I believe that the gnuradio usrp2 driver defaults to using only RXA for
>> the BasicRX board. This can be changed by modifying this value in
>> firmware for lib/db_basic.c to be "true" for the following line:
>> .base.is_quadrature = false,
>> As an alternative, I recommend trying the UHD:
>> http://ettus-apps.sourcerepo.com/redmine/ettus/projects/uhd/wiki The
>> basic board defaults to using both RXA and RXB, and the selection is
>> software configurable.
>> -Josh
>> On 08/26/2010 03:48 AM, Cheaw Wen Guey wrote:

Cheaw Wen Guey
Research Officer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]