[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] find_usrps only succeed when an sniffer is ON

From: Jorge Miguel
Subject: Re: [Discuss-gnuradio] find_usrps only succeed when an sniffer is ON
Date: Wed, 8 Sep 2010 09:18:10 +0200


I set permissions as you said:
     /usr/bin$ sudo chmod 4775 usrp2_socket_opener
However it does not fix the problem. Only when setting my Ethernet
interface to promiscuous mode with:
     sudo ifconfig eth0 promisc up
'find_usrps' does work perfectly.
If I execute
     sudo ifconfig eth0 -promisc
Again there is no connection with the USRP2

Is there any other file which needs permissions ?

>What are the permissions on:


>They need to be 4755 in order for non-privileged apps to work correctly
>with the raw ethernet interface.

>Marcus Leech
>Principal Investigator
>Shirleys Bay Radio Astronomy Consortium

>>On 09/07/2010 03:12 PM, Jorge Miguel wrote:
>> Thanks for your quick answer. A problem with a firewall was an idea
>> that also came to my mind but I disabled the Ubuntu firewall with the
>> command "sudo ufw disable" so that no firewall is running into my
>> machine and the USRP2-Host computer connection is made directly with a
>> 1 Gb ethernet wire.
>> Furthermore there were no errors during the installation of the
> >software (via package manager).I run out of ideas....any suggestion?
>> Jorge.
> >On 09/07/2010 04:43 AM, Jorge Miguel wrote:
> >
>> >I installed GNU Radio on a ThinkPad Lenovo T4410 under Ubuntu 10.04.
>> >After connecting the USRP2 with the original Ettus code on the SD card
>> >D and F LEDs are ok and when executed:
>> >~$ sudo find_usrps
>> >No USRP2 found.
>>> I run wireshark or tcpdump to see what happens in my network and I got:
>> >~$ sudo find_usrps
>> >00:50:c2:85:35:a2 hw_rev = 0x0400
>> >If I stop the sniffer, I get again:
>>> ~$ sudo find_usrps
>>> No USRP2 found.
>> >My problem is that 'find_usrps' only works when a sniffer is running.
>> >How can it be explained?
>>> Jorge,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]