[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] detecting spectrum holes

From: Abdelrahman Ahmed
Subject: Re: [Discuss-gnuradio] detecting spectrum holes
Date: Thu, 22 Mar 2012 15:38:18 +0200

MY problem
hi ,
problem 1
i pugged usrp into usb and run usrp_fft.py and i got signal like noise it's
amplitude -60 dB.
i also can run usrp_spectrum_sense.py but only numbers of frequencies
appeared below each other (min freq and max freq).

problem 2
when i plugged out usrp from usb and run usrp_fftw.py again  it told me
that can not open usrp.
and when i try benchmark_tx.py and benchmark_rx.py on the other lap, there
is an error appeared told me that
can not find module usrp_transmit_path

problem 3
- when i write usrp_probe i can not get any info about my usrp1.
- when i write uhd_find_devices it told me that:

Could not locate USRP1 firmware

Please install the images package

so from these problems some programs can identify the usrp1 and the
other not, so what is happening here.

Abdelrahman ahmed


arab academy for science and technology and maritime transport

Discuss-gnuradio mailing list


Problem 1: Please describe your hardware setup so that we can help:

a) What USRP model are you using? What GNUradio version, did you install the distribution package on Ubuntu 8.04 or upgrade to 11.10 as suggested? What was the exact command line you used for usrp_spectrum_sense.py and usrp_fft.py?
b) What daughterboard did you install inside the USRP? How did you connect it to the USB port of your laptop, and how to the antenna?
c) Is the USRP powering up?
d) After a power cycle (everything just switched on), does uhd_find_devices still give you nothing? what about lsusb -v?

In case you managed to get up to d) and have the USRP and daughterboard(s) detected correctly,

e) Did you connect the antenna to the appropriate RX channel of your daughterboard? When using WBX, there's an RX and an RX/TX port, so if you connect the antenna to the wrong port, you might only see noise except for a few *very* strong local sources. Try tuning to a local FM radio station... Any antenna should do for this purpose, even a paperclip - but don't torture the gold plated SMA connectors of the USRP with that :)

Problem 3 is probably caused by Problem 2. I also noticed that sometimes the USB stack seems to get messed up, so you might want to try a) power cycling your USRP and if that doesn't help, b) power cycling the laptop connected to the USRP.


frist of all i have two laptops with ubuntu 11.10 x32bit installed inside windows 7 professional x64, i used this link in synaptic to install gnuradio packages:

11.10 contains 3.2.2.dfsg-1ubuntu7 (http://packages.ubuntu.com/oneiric/gnuradio)

 and this guide to install the other packages :


After successful installation still there is UHD, i installed it through this:

git clone git://code.ettus.com/ettus/uhd.git

cd uhd/host

mkdir build

cd build

cmake ../


make test

sudo make install

#Check where your path is with "find |grep libuhd"

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

after that i checked:
python worked
gnuradio-companion worked
gnuradio worked

so guide me if i mess something or did something wrong in installation step ?
i will provide you with other information about hw setup and what each usrp box contain? in Saturday

reply via email to

[Prev in Thread] Current Thread [Next in Thread]