[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] tunnel.py command not working

From: M. Ranganathan
Subject: Re: [Discuss-gnuradio] tunnel.py command not working
Date: Fri, 29 Mar 2013 16:00:54 -0400

There's stuff missing in tunnel.py. The receiver has to return ICMP echo reply. Instead it writes to the tunnel socket. The packet will get to the kernel but will be promptly dropped as it has a source address that does not originate locally.

Add code in tunnel.py to do an icmp echo reply.

On Wed, Mar 27, 2013 at 11:54 AM, Nada ABDELKADER <address@hidden> wrote:

I tried to run tunnel.py on my machine (Ubuntu 11.10) with 2 USRPs (usrp1).

from one side I launched:
./tunnel.py --tx-freq 2.4G --rx-freq 2.4001G -a="name=dev1" -A TX/RX --bitrate 500k -v
then :
sudo ifconfig gr0
from another terminal (on the same machine):
./tunnel.py --rx-freq 2.4G --tx-freq 2.4001G -a="name=dev0" -A TX/RX --bitrate 500k -v
sudo ifconfig gr1
But when I run ping from both sides I see nothing displayed!
Is what I've done correct? Is it possible to use one machine? What did I miss?
Can you help me plz!

Best Regards,

This message was sent using IMP, the Internet Messaging Program.

Discuss-gnuradio mailing list

M. Ranganathan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]