[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Building a Zedboard BOOT.bin

From: Daniel Camara
Subject: [Discuss-gnuradio] Building a Zedboard BOOT.bin
Date: Thu, 23 Oct 2014 16:20:53 +0200


  I am trying to generate a bootable SD card for the zedboard and I am running over some small issues. For starters, do you provide the u-boot.elf you use somewhere? In the http://gnuradio.org/data/sdk/zedboard_armv7a-hf-vfp-neon/ there is only the uboot.bin, but the boot.bif at zynq-acp/top/zedboard/boot requires the .elf.

  I tried to build everything as described in the "Building the Linux Kernel, U-Boot, & Root Filesystem with OpenEmbedded" section but then... I run into  MANY issues  building it, (really many,  I am writing down everything and, if I manage to do it fully one day, I already promised I will  contact the write all the issues and I will try to contact the responsible for the module to share my findings, it may help the next people :). For the moment I got stuck at:
configure:18748: error: in `..../oe-repo/build/tmp-eglibc/work/armv7a-vfp-neon-oe-linux-gnueabi/libxt/1_1.1.4-r0/libXt-1.1.4':
configure:18750: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables XT_CFLAGS
and XT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see <http://pkg-config.freedesktop.org/>.
See `config.log' for more details


| ERROR: Function failed: do_configure (log file is located at ..../oe-repo/build/tmp-eglibc/work/armv7a-vfp-neon-oe-linux-gnueabi/libxt/1_1.1.4-r0/temp/log.do_configure.19545)
ERROR: Task 3409 (.../oe-repo/oe-core/meta/recipes-graphics/xorg-lib/libxt_1.1.4.bb, do_configure) failed with exit code '1'


  Any ideas? I looked into the libxt_1.1.4.bb to see what I could change... but as  I never used bitbake nor have I ever create a recipe... I am afraid of breaking something if I just disable it.

  By the way, is there any chance some one will try to adapt the ISE scripts to vivado? The XPS tool, used in the scripts, does not exist anymore :(. I installed  the evaluation version to create the fsbl.. but I guess more and more people will run over this problem of compatibility of the present scripts with the new version of the Xilinx tools.

   Best regards...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]