[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Issue trying to run simple_ra

From: Marcus D. Leech
Subject: Re: [Discuss-gnuradio] Issue trying to run simple_ra
Date: Tue, 18 Oct 2016 20:57:14 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.7.0

On 10/18/2016 07:36 PM, Jose Ruvalcaba wrote:

I installed and tried to run the simple_ra_receiver flowgraph using a USRP N210 and was shown the following error message:

aster$ simple_ra
Using Volk machine: avx_64_mmx_orc
gr-osmosdr v0.1.4-75-gae686c46 (0.1.5git) gnuradio 3.7.9
built-in source types: file fcd rtl_tcp rfspace redpitaya
WARNING: Overriding original sample rate of 1e+07 with 2e+06
Traceback (most recent call last):
  File "/home/ubuntu/bin/simple_ra_receiver.py", line 2574, in <module>
  File "/home/ubuntu/bin/simple_ra_receiver.py", line 2569, in main
  File "/usr/lib/python2.7/dist-packages/grc_gnuradio/wxgui/top_block_gui.py", line 74, in Start
  File "/usr/lib/python2.7/dist-packages/gnuradio/gr/top_block.py", line 109, in start
    top_block_start_unlocked(self._impl, max_noutput_items)
  File "/usr/lib/python2.7/dist-packages/gnuradio/gr/runtime_swig.py", line 5678, in top_block_start_unlocked
    return _runtime_swig.top_block_start_unlocked(r, max_noutput_items)
RuntimeError: resolve_port: hierarchical block 'source_impl': output 1 is not connected internally

I updated osmosdr to the latest version from https://github.com/osmocom/gr-osmosdr
but I still get the same issue.

Any ideas?


You don't appear to have UHD compiled-in to your gr-osmosdr, so that's one problem.

How did you build GR + friends?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]