[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] USRP N210 MIMO

From: Marcus Müller
Subject: Re: [Discuss-gnuradio] USRP N210 MIMO
Date: Wed, 15 Feb 2017 13:32:51 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.2.0

Hi Roohollah,

Fully agreeing with Kyeong Su Shin; you need Gigabit Ethernet. And to confirm: rx_samples_to_file is just an example of how to collect samples to a file and does no synchronization (you might want to read the source code of rx_timed_samples, if you're interested in how that could work, but that is also just an example and doesn't do the right kind of timed command tuning, IIRC).

Best regards,


On 02/15/2017 04:13 AM, Kyeong Su Shin wrote:
Hello Roohollah Parvizi:

-There could be many reasons, but first, you want to check the link speed that you are getting from the switch (requires 1000Mbps connection - 100Mbps won't work).

-rx_samples_to_file is part of UHD (not GNURadio application, although somewhat related). I believe it is not capable of MIMO synchronization without modifications (please correct me if I am wrong). You can download its source code from the UHD Github project and adapt it if you want. 

-It is probably easier to use GNURadio. I am actually not sure if you have GNURadio on your system, since that rx_samples_to_file is bundled with UHD, not with GNURadio. Anyway, if you have it installed on your PC, you should be able to use GNURadio Companion to write a short program out of it. On GNURadio Compaion, you should add a "UHD: USRP Source" block and set "Num Mboards" = 2 and match settings with your configurations (Will have to set device address, Mb0/1 Clock/Time source, etc).

Kyeong Su Shin

On Tue, Feb 14, 2017 at 3:01 PM, Roohollah Parvizi <address@hidden> wrote:

Hello all,

I am using the two USRP N210 with the SBX daughter board for the MIMO system. first, I changed the IP address of the second USRP to “ip-addrs=” and the name of both USRP’s as well.

I have these issues for setting the MIMO system,

·         I connected both USRP’s via the Netgear switch to the host computer. Unfortunately, I did not get any respond from the USRPs (none of them). I checked “uhd_find_devices” and the output was “ no USRP devices found “  Even I tried the single USRP using the switch I had the same issue.

·         After I was unsuccessful using the switch, I tested the MIMO cable without the switch (I mean I connected device 1 to the device 0 via the MIMO cable and then connected device 0 to the host computer), it worked. So, I started collecting the sample data using the “rx_samples_to_file_.exe” command. For getting sample data from both USRPs simultaneously I used the “ rx_samples_to_file --args=”addr=” --freq 1575.42e6 --gain 30 --rate 10e6  --duration 30  usrp_dir_G30_samples.dat  addr=  --freq 1575.42e6 --gain 30 --rate 10e6  --duration 30  usrp_reflect_G30__samples.dat “ ( the brief version of command ). However, it failed. Therefore, I executed those commands individually. Since I wanted to acquire signals simultaneously, I executed those commands separately at the different windows command prompt. My question is that is there any way to execute those commands as a block? Or is there a single command to force both USRP to start getting data?

Could you please help me with those issues?


Thanks in advance,


Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]