[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Linking Armadillo and LAPACK to gnuradio

From: Richard Mcallister
Subject: [Discuss-gnuradio] Linking Armadillo and LAPACK to gnuradio
Date: Fri, 24 Feb 2017 14:31:27 -0500

Hey all,

This might be more of an error with cmake or armadillo, but I've been trying to use armadillo in an OOT module. I've called make and built the module, no issues with missing libraries or anything. Pybombs tells me that armadillo is installed, along with blas and lapack. I'm using the latest gnuradio update, and I'm on Ubuntu 16.04

However, when I run 'ctest -V -R'
Test timeout computed to be: 9.99988e+06
3: Traceback (most recent call last):
3:   File "/home/rich/Desktop/repos3/gr-vlp2/python/qa_amp2d_ff.py", line 24, in <module>
3:     import vlp2_swig as vlp2
3:   File "/home/rich/Desktop/repos3/gr-vlp2/build/swig/vlp2_swig.py", line 28, in <module>
3:     _vlp2_swig = swig_import_helper()
3:   File "/home/rich/Desktop/repos3/gr-vlp2/build/swig/vlp2_swig.py", line 24, in swig_import_helper
3:     _mod = imp.load_module('_vlp2_swig', fp, pathname, description)
3: ImportError: /home/rich/Desktop/repos3/gr-vlp2/build/lib/libgnuradio-vlp2.so: undefined symbol: wrapper_sgelsd_

All of the tests in the OOT modules fail (except test_vlp2), including blocks that don't use armadillo. I've looked at gr-specest and added the following lines to my CMakeLists.txt:
find_package(BLAS REQUIRED)
find_package(LAPACK REQUIRED)

and still get the same issues. I'm pretty sure cmake is missing something, I'm just not sure what. Has anyone else had issues with this before?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]