[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] AirSpy HF+ with GNU Radio and gr-osmosdr

From: Geof Nieboer
Subject: Re: [Discuss-gnuradio] AirSpy HF+ with GNU Radio and gr-osmosdr
Date: Mon, 24 Sep 2018 17:22:16 -0400

Glad to help! 

On Mon, Sep 24, 2018 at 2:40 PM Richard Hedlund <address@hidden> wrote:
Hello Geof and Kyeong,

Thank you for such quick response.

I started with your suggestions Kyeong, i had udev rules set in /etc/udev/rules.d for the device. I tried running GNU Radio as root, still without luck.

As for your suggestion Geof, to play with the arguments for the osmocom source block in GNU Radio, this actually solved my problem, however not in the way i expected. I have of course tried "airspy", "airspy=0", etc, as the argument for the source block which is suggested in the documentation at

Then i though why not try "airspyhf=0"...

No where in any documentation that i found is it stated that i should use "airspyhf=0". THIS solved the problem. Perhaps this is obvious for all of you, but it is not for a newbie like me.

Finally! My week long headache was solved by a simple argument line in the source block.

Hopefully my embarrassment will help someone else out there. Thank you for your help! This thread can be marked as solved.

Kind regards,

Den mån 24 sep. 2018 kl 18:18 skrev Geof Nieboer <address@hidden>:
I would recommend experimenting with the osmosdr source parameters.  GQRX uses GNURadio behind the scenes, so if GQRX can see it in Ubuntu, then so should GNURadio, so I suspect it's a block setup problem.

On Mon, Sep 24, 2018 at 7:35 AM Richard Hedlund <address@hidden> wrote:

First of all, this is my first post on a mailing list and i apologize if this is the wrong place to ask this kind of question.

After having spent almost a full work week on getting the AirSpy HF+ to work with GNU Radio i thought it was time to post here. It feels like i have searched everywhere; different mailing lists, forums, AirSpy support along with their github and the web in general.

I have tried installing GNU Radio using pybombs following the guide:

I have tried installing GNU Radio following the guide by Alexandru Csete:

I have tried building and installing:

The AirSpy HF+ works with:
SDR# under Windows 10
GQRX under the Ubuntu system below

I does however not work with GNU Radio under Linux which is were i intend to use the HF+.

My system info (Dell Latitude 7480):
  • Ubuntu 18.04.1 LTS (full installation on a USB-stick)
  • 4.15.0-34-generic #37-Ubuntu SMP Mon Aug 27 15:21:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
  • 16 GB RAM
  • Intel Core i7 7600U
Output of: dmesg | grep usb
[ 7243.420121] usb 1-2: new high-speed USB device number 13 using xhci_hcd
[ 7243.569041] usb 1-2: New USB device found, idVendor=03eb, idProduct=800c
[ 7243.569052] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7243.569060] usb 1-2: Product: AIRSPY HF+
[ 7243.569067] usb 1-2: Manufacturer: www.airspy.com
[ 7243.569074] usb 1-2: SerialNumber: AIRSPYHF SN:3652A98094C73FA0

Output of: airspy_info
airspy_lib_version: 1.0.9
airspy_open() board 1 failed: AIRSPY_ERROR_NOT_FOUND (-5)

Running GNU Radio:
I try to run a simple flowgraph in GNU Radio with an osmocom source connected to a WX gui FFT sink. The output is the following:

Generating: '/home/hedric/top_block.py'

Executing: /usr/bin/python -u /home/hedric/top_block.py

Warning: failed to XInitThreads()
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

gr-osmosdr v0.1.x-xxx-xunknown (0.1.5git) gnuradio 3.7.11
built-in source types: file osmosdr fcd rtl rtl_tcp uhd plutosdr miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp
Traceback (most recent call last):
  File "/home/hedric/top_block.py", line 101, in <module>
  File "/home/hedric/top_block.py", line 95, in main
    tb = top_block_cls()
  File "/home/hedric/top_block.py", line 65, in __init__
    self.osmosdr_source_0 = osmosdr.source( args="numchan=" + str(1) + " " + 'airspy=0' )
  File "/usr/lib/python2.7/dist-packages/osmosdr/osmosdr_swig.py", line 1170, in make
    return _osmosdr_swig.source_make(*args, **kwargs)
RuntimeError: Failed to open AirSpy device (-5) AIRSPY_ERROR_NOT_FOUND

Hopefully this is enough information for you, if not please let me know. I am by no means an advanced Linux user but still eager to learn.

Kind regards,
Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]