discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem configuring gnustep-core


From: David Relson
Subject: Problem configuring gnustep-core
Date: Tue, 02 Jan 2001 12:01:57 -0500

Happy New Millenium!

It's been a while since I last built GNUstep and I'm having trouble. My sources are all in /usr/src/GNUstep and I can easily build dgs/tiff, gnustep/core/make, and gnustep/core/base. However if I run "./configure" from directory /usr/src/GNUstep/gnustep/core, I get the following:

...
checking for -ltiff without -ljpeg nor -lz... no
checking for -ltiff without -lz... no
checking for TIFFReadScanline in -ltiff... no
configure: warning: Cannot find libtiff
* The GUI library reqiures the TIFF library
* Use --with-tiff-library to specify the tiff library
* directory if it is not in the usual place(s)
* You may also have to specify --with-jpeg-library if the jpeg
* Library is needed by tiff
configure: error: You must have proper libraries installed to compile core
configure: error: /bin/sh ./configure failed for make

Checking for libtiff.a, I have it in two spots (as expected):
-rw-r--r-- 1 root root 1181902 Jan 2 10:50 /usr/src/GNUstep/dgs/tiff/libtiff/libtiff.a -r--r--r-- 1 root root 1181902 Jan 2 10:51 /usr/GNUstep/System/Libraries/ix86/linux-gnu/libtiff.a

Environment variable LD_LIBRARY_PATH does contain /usr/GNUstep/System/Libraries/ix86/linux-gnu.

Other information of possible significance:
        Distribution:   Mandrake 7.2
        Kernel:         2.2.18
        CPU:            Pentium III
        libtiff-3.5.5-2mdk.rpm is installed

configure mentions option "--without-tiff_library", though it doesn't use it (as far as I can tell). I tried it anyhow, but it didn't help.

Anybody familiar with this problem and the solution?

Thanks.

David


--------------------------------------------------------
David Relson                   Osage Software Systems, Inc.
address@hidden       Ann Arbor, MI 48103
www.osagesoftware.com          tel:  734.821.8800




reply via email to

[Prev in Thread] Current Thread [Next in Thread]