[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GORM in Gnome (Was - So, honestly, is GNUStep a viable development optio

From: Mark Grice
Subject: GORM in Gnome (Was - So, honestly, is GNUStep a viable development option?)
Date: Tue, 13 Nov 2007 08:51:27 -0500

It is 100% reproducible here -- it happens every time I do it. Do you
want me to put a bug report in somewhere? (would that be a GORM bug, a
PC bug or a GNUSTEP bug?)  Or does someone else want to verify this on
their system?

BTW, If I DON'T double click the .gorm file, but rather open it up in
GORM (in other words, instead of using Project Center to launch GORM,
I launch it myself and then open the same project from there) it works
fine. (Although, it does not have the windows open the tutorial
assumes it does... I was able to figure that out after a bit of poking
and clicking...)

Also, I had a similar behavior when running some of the examples. It
may be as you say, when it sees an error, it punts to WindowMaker...
but this is not expected behavior...

On Nov 13, 2007 8:39 AM, Nicolas Roard <address@hidden> wrote:
> Hi,
> On Nov 13, 2007 1:13 PM, Mark Grice <address@hidden> wrote:
> > Thanks for the replies. It was a relief to wake up this morning and
> > see that the mailing list is active, I sent an email to the Etoille
> > list days ago (a lot less flammatory, btw) and still have not seen any
> > reply. So maybe at least part of my tone came from frustration.
> >
> > A couple of things, but let me start with this one:
> >
> > The WMAKER link I described is more than a misconception, I think.  It
> > happens when following the tutorial for Project Center and Gorm! Let
> > me tell you what I did, and you tell me what I did wrong... (I am
> > working in UBUNTU Gnome 7.10)
> >
> > Following the tutorial script: I run Project Center. Create a new
> > project. Click on "Interfaces" and then double click on the
> > Convertor.gorm file... and I find myself staring at a WindowMaker
> > screen that is pretty much non functional. I have to CTRL-ALT-DEL and
> > log off my session to get control back.
> It _may_ be that something (ProjectCenter ? Gorm ? ...) crashes your current
> gnome windowmanager  (or the gnome session manager ?) -- which would
> results in what you describe, as iirc ubuntu uses windowmaker as a
> failsafe wm if the current one crashes. I vaguely remember it happening to
> me (though not because of gnustep).
> So basically your session crashes and windowmaker is started.
> > This tells me that I cannot really run GNUStep in Gnome. Things
> > function as the tutorial says they will if I run them in Window Maker.
> >
> > I assumed that this was expected behavior, since the GNUStep home page
> > pretty much tells you to use Window Maker... so I didn't want to call
> > it a bug. If it is a bug, I will be happy to enter it as such...
> I'm not sure a lot of people uses gnustep under gnome, but if that's
> reproducible we should definitely investigate.
> --
> Nicolas Roard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]