discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

half way easy - installing GNUstep using gnustep-startup-0.19.0.tar.gz o


From: Lars Sonchocky-Helldorf
Subject: half way easy - installing GNUstep using gnustep-startup-0.19.0.tar.gz on a Mac
Date: Sat, 1 Dec 2007 01:40:15 +0100

Out of curiosity I tried how *easy* it is to install GNUstep from scratch using gnustep-startup-0.19.0.tar.gz on a Mac.

For that purpose I freshly installed Mac OS X 10.4 onto a spare partition, updated it to the latest version (10.4.11) installed all fixes and the latest DevTools (Xcode 2.5)

Then I booted from that partition, downloaded gnustep- startup-0.19.0.tar.gz, unzipped it (double-clicking it in Finder), read INSTALL and README, followed the provided links (btw. http:// www.gnustep.org/resources/documentation/User/GNUstep/README.Darwin needs an update) and finally opened a terminal window:

lars-sonchocky-helldorfs-powerbook58:~ lars$ cd /Users/lars/Desktop/ gnustep-startup-0.19.0/ lars-sonchocky-helldorfs-powerbook58:~/Desktop/gnustep-startup-0.19.0 lars$ sudo ./InstallGNUstep


Off course (I knew it before) this wasn't the end of this story, InstallGNUstep barked on me:


*********************************************************************
* Startup configuration report                                      *
*********************************************************************
--------------------------------------------------------------
E093 Error
It appears you are using the Apple cc compiler. The Apple compiler does
not compile GNUstep.
You need to install an FSF compiler, or make sure that the FSF
compiler is found first in your PATH.
--------------------------------------------------------------
I199 Information
GNUstep is not installed yet. Please proceed with installation of GNUstep
as long as you have resolved other errors listed here.
--------------------------------------------------------------
W272 Warning
You do not have a recent version of the libobjc library. Startup
will install one.
--------------------------------------------------------------
W403 Warning
You need to install the JPEG library (libjpeg)) in order to load JPEG
images with the GNUstep gui.
--------------------------------------------------------------
E401 Error
You need to install the TIFF library (libtiff and libtiff-devel) in order
to use the GNUstep gui.
--------------------------------------------------------------
W409 Warning
You need to install the PNG library (libpng) in order to load PNG
images with the GNUstep gui.
*********************************************************************
Please correct the above errors before installing GNUstep
If you don't understand something or think a test is in error,
please email address@hidden and send the /Users/lars/Desktop/ gnustep-startup-0.19.0/build/logs.tar.gz file lars-sonchocky-helldorfs-powerbook58:~/Desktop/gnustep-startup-0.19.0 lars$


O.k. FSF-gcc is missing. For good I know (http://gcc.gnu.org/ml/gcc/ 2005-04/msg00536.html) what to do:

- go to http://gcc.gnu.org/
- click onto "releases" -> http://gcc.gnu.org/releases.html
- click onto "GCC 4.2.2" -> http://gcc.gnu.org/gcc-4.2/
- click onto "our mirror sites" -> http://gcc.gnu.org/mirrors.html
- click onto a mirror -> Finder window with that mirror opens.
- navigate to releases/gcc-4.2.2/
- choose the right version -> drag gcc-4.2.2.tar.gz to the desktop
- wait ...
- unpack gcc-4.2.2.tar.gz using command line (the Finder had issues here in former times - I don't know if those are still present):

cd Desktop/
tar -zxf /Users/lars/Desktop/gcc-4.2.2.tar.gz
mkdir gcc-4.2.2-build
cd gcc-4.2.2-build/
../gcc-4.2.2/configure --prefix=/opt/local
make bootstrap
sudo make install

- this took several hours (I don't know how many at all since I went to bed after 2 1/2 hours and did the 'sudo make install' the next day)


- I use this time to look around for easy ways (beside macports ;-)) to install libjpeg, libtiff and libtiff-devel, libpng:

- at first I found http://developer.apple.com/internet/opensource/ php.html which looks officially. But that uses fink which is similar to macports. I don't want to trick myself - so this is no option.

- I found http://snippets.dzone.com/posts/show/38, http:// freshmeat.net/projects/libjpeg/ and http://www.ijg.org/ for libjpeg - I downloaded the libjpeg sources from ftp://ftp.uu.net/graphics/ jpeg/ (lots of files there, but the README told me to choose jpegsrc.v6b.tar.gz)

- libtiff was more difficult (everyone seems to use macports or fink these days) so I resorted to http://www.libtiff.org/ - I finally downloaded tiff-3.8.2.tar.gz from http://dl.maptools.org/ dl/libtiff/ since the main site ftp://ftp.remotesensing.org/pub/ libtiff did not work


- to compile those libs I want to use the freshly build gcc. To avoid permanent changes to my setup (who knows if I want to use the Apple- gcc later for other purposes) I decided to set the PATH only temporarily:

which gcc
-> /usr/bin/gcc
PATH=/opt/local/bin:$PATH
which gcc
-> /opt/local/bin/gcc


- then I started with libjpeg according to http://snippets.dzone.com/ posts/show/38

- I had to change 'cp /usr/share/libtool/config.sub .' to 'cp /usr/ share/automake-1.6/config.sub .' and 'cp /usr/share/libtool/ config.guess .' to 'cp /usr/share/automake-1.6/config.guess .' since the former was not there

- I also added '--prefix=/opt/local' to './configure --enable-shared --enable-static'

cd ~/Desktop/jpeg-6b/
cp /usr/share/automake-1.6/config.sub .
cp /usr/share/automake-1.6/config.guess .
./configure --enable-shared --enable-static --prefix=/opt/local
make
sudo make install
sudo ranlib /opt/local/lib/libjpeg.a


- next was libtiff, the README contained all information needed, I just added '--prefix=/opt/local' to './configure'

cd ~/Desktop/tiff-3.8.2
./configure --prefix=/opt/local
make
sudo make install


- then I found the libpng sources here: http://www.libpng.org/pub/png/ libpng.html and downloaded them from here: http:// prdownloads.sourceforge.net/libpng/libpng-1.2.23.tar.gz?download

- the INSTALL document was helpful again

cd ~/Desktop/libpng-1.2.23
./configure --prefix=/opt/local
make check
sudo make install


- after all that it was time to try the InstallGNUstep again. Now everything worked flawlessly.

- In the end the following message appeared: "Now you can install some applications and start using GNUstep Look for a few applications in the AppSources directory." However, I wasn't able to locate that directory anywhere.

- To test GNUstep I downloaded the Gorm Sources, installed Gorm and was even able to open a Nib of Apple's TextEdit (see attached Screenshot) with it. Great Work!


Conclusion:

Installing GNUstep using gnustep-startup is quite easy and straight forward given that the target system already has the dependencies installed. This might be the case for a great many of Linux systems (although I ran across several Linuxes that came with a gcc missing ObjC support (I remember SuSE 7.1 PPC here) it is definitely not the case for OS X - which is where a fair amount of our current target audience (read: folks we don't need to explain OpenStep/Cocoa to) sits. Installing all those dependencies might be a no-brainer for a seasoned UNIX crack but is nearly incomprehensible for a newbee. The major obstacle was clearly gcc itself (although the installation of it is now easier than it used to be): The right version of the sources it not easy to find, it takes ages to install and it will conflict (in OS X's case) with Apple's gcc.

Maybe those issues are solvable when installing at least the dependencies using the packaging/ports system for the particular platform. Then again it would be great if GNUstep itself was also available at those packaging/ports systems (It is at least available for macports - even though I don't know it's current status of maintenance.)

Another idea would be - like Dr Toma┼ż Slivnik proposed - to provide binaries but this is IMHO only feasible for well defined platforms like Windows or Mac OS X - btw. what is the status of the Windows- installer - is it still maintained?

And last but not least the question: Why don't we include Gorm and ProjectCenter into gnustep-startup? This way there would be to apps for trying out GNUstep already which also suit a purpose later on.


regards,

        Lars

Attachment: Gorm
Description: application/applefile

PNG image


reply via email to

[Prev in Thread] Current Thread [Next in Thread]