[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Terminal.app and fonts

From: Pablo Giménez
Subject: Terminal.app and fonts
Date: Thu, 8 Oct 2009 17:46:12 +0100

Hi everybody, et least I have the GNUstep environment working, all the core, extra libs, GWorkspace and SystemPreferences.
Well today I tred Terminal.app to complete my working tools.
I got it from the GAP, is version 0.9.5. It works.
But I tried to change the default Courier 12 forn. First I changed it from the Terminal.app preferences to Helvetica 9 and the app crashed.
I tred to open it from a terminal and I got an error like Helvetica font of size can't be found , and then a segfault:
So from this point I couldn't startt Terminal.app again.
I tried to change the default GNUstep font from SystemPreferences.app, which is still to Courier 12, just change to Courier 10, and revert to 12 again, and then when trying to start Trminal I got this error:

2009-10-08 12:41:59.933 Terminal[22454] NSFont <NSFont: 0x1261450> Courier 12.000 0.000 0.000 12.000 0.000 0.000 N P 0 info <XGFontInfo: 0x1263f30> size 12 {x = 0; y = 0; width = 7; height = 8} 1
Segmentation fault

Also using the defaults command I have tried to look for the key NSFontm, which seems to exists only for the NSGlobalDomain domain, there is no font key for the Terminal.
So is there any way I can reset the fonts for the Terminal.app so I can use it again. Why the Terminal.app is crashing when I set the font for example to Helvetica.

And talking about fonts, cam GNUstep use True Type fonts? and is possible to use Xft to get antialiased fonts?


Un saludo
Best Regards
Pablo Giménez

reply via email to

[Prev in Thread] Current Thread [Next in Thread]