[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bean through GnuStep - newbie on Linux question

From: Sebastian Reitenbach
Subject: Re: Bean through GnuStep - newbie on Linux question
Date: Thu, 16 Feb 2012 10:32:35 +0100
User-agent: SOGoMail 1.3.12

On Thursday, February 16, 2012 09:46 CET, Fred Kiefer <fredkiefer@gmx.de> 
> On 16.02.2012 08:57, Riccardo Mottola wrote:
> > On 02/15/12 23:07, springbunny11@gmail.com wrote:
> >> I presently use the excellent word processor for mac called Bean. The
> >> author of Bean said he believed a version for Gnustep was created.
> > The author is right. We "forked" a snapshot and are trying to port it to
> > GNUstep. Actually, we also try to make GNUstep work for it, so it is a
> > testbed for Mac compatibility in terms of the build-tool, NIB
> > compatibility, etc. (Another candidate in this direction is FlexiSheet,
> > the spreadsheet). It was never perfect, but I have noticed it broke
> > quite badly lately, so we need to check why it is now an ill
> > patient.It's sad, because FlexiSheet instead improved a lot, so I hoped
> > Bean would benefit from it.
> Could you please detail what got broken in Bean with the new GNUstep 
> release?
> The only issue I am aware of is that Bean has some default values for 
> colour stored in a defaults.plist. Now that GNUstep gui actually 
> supports bindings for user defaults these get loaded and an NSUnarchiver 
> is used here, as the bindings are set up with an 
> NSUnarchiveFromDataTransformer. The actual values stored in the 
> defaults.plist are keyed archived and the archiver used is a non-keyed, 
> so this fails. We will either have to find a better solution here in 
> base or to get Bean working again, remove the current values from the 
> defaults.plist. As we exchanged quite a few mails on this, I would think 
> that this has been done a long time ago in Bean.
> The strange thing about these NSUnarchiveFromDataTransformer is that I 
> have seen archives using one or the other archive form. No idea how this 
> is supposed to work. I changed the behaviour in response to bug report 
> #34760 (https://savannah.gnu.org/bugs/index.php?34760).
> Here it would help to understand where the defaults.plist in Bean comes 
> from. Was it create on Cocoa or GNUstep? In the later case we just need 
> to recreate it.

as far as I can tell from the small tests I did shortly before the FOSDEM:

It builds and starts up fine, but when I actually want to enter text it doesn't 
take it, the cursor stays at its position.
When starting to type,  some menu icons change from active and inactive or the 
other way around, so it somehow
recognized that I'm typing. I don't know what the actual problem, is, and 
whether its related at allto what you describe.
I never tried Bean before, so I cannot tell whether it worked before.


> Fred
> _______________________________________________
> Discuss-gnustep mailing list
> Discuss-gnustep@gnu.org
> https://lists.gnu.org/mailman/listinfo/discuss-gnustep

reply via email to

[Prev in Thread] Current Thread [Next in Thread]