[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs under GNUstep

From: Citizen Jimserac
Subject: Re: Emacs under GNUstep
Date: Fri, 8 Feb 2013 15:48:35 -0800 (PST)
User-agent: G2/1.0

On Feb 8, 11:40 am, Fred Kiefer <address@hidden> wrote:
> On 08.02.2013 15:32, Citizen Jimserac wrote:
> > On Feb 7, 12:58 pm, Germ n "A. Arias" <address@hidden> wrote:
> >> Try with the latest pretest:
> >>  ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-24.2.93.tar.xz
> >> This have improvements to compile with GNUstep.
> > Tried to configure and compile but after ./configure
> > checking for X... true
> > configure: error: You seem to be running X, but no X development
> > libraries
> > were found.  You should install the relevant development files for X
> > and for the toolkit you want, such as Gtk+, Lesstif or Motif.  Also
> > make
> > sure you have development files for image handling, i.e.
> > tiff, gif, jpeg, png and xpm.
> > If you are sure you want Emacs compiled without X window support, pass
> >    --without-x
> > What libraries it want? I have gtk+ and lesstif.   Or does it want
> > development versions of these libraries.
> > Also, I already have tiff, giff, jpeg etc. libraries installed.  Or
> > does it want development versions of these too?
> You will need the development version of all these plus the one it is
> asking for, libX11-dev or what ever it is called on your system. You may
> even need more packages, but the configure code can only tell you about
> them after you resolved the first issues.
> I tried to compile the 23 version of the GNU Emacs for GNUstep and
> failed with that, but that was some time ago. I did not try any 24 release.
> Fred

Well I found the needed missing libraries.  They were:

yum install Xaw3d-devel libXp-devel libXaw-devel

and I also did

yum install libXt-devel libext-devel readline-devel

That seemed to make ./configure happy except for the gif library which
yum could not find so I configured without it.

But ./configure appears to have made a Makefile, not a GNUMake

Compile went OK, only I have no idea where it put the binary.

Will study the makefile later and see.

Meanwhile, back to pixen....


reply via email to

[Prev in Thread] Current Thread [Next in Thread]