[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Duplicity-talk] Duplicity backup to rsync.net

From: Peter McCrackan
Subject: [Duplicity-talk] Duplicity backup to rsync.net
Date: Thu, 14 Jan 2010 08:15:39 +0800

I have tried both with and without the -v9 switch (as per instructions at http://www.rsync.net/resources/howto/duplicity.html ), both give the same result.
I have got the SSH key setup, as root I can log into my rsync.net file system without entering a password.
I have got my GPG key setup and get the expected results when listing it.
It is not asking my for my passphrase when I run the command below, just says it cannot import the GnuPGInterface.

I have changed my rsync.net account details, the account details below are fictitious.

duplicity full -v9 --encrypt-key="2F1A3E29" /media/b580000f-33eb-4192-91f9-f8d8d2a4024c/share/current  scp://address@hidden/dup-baks
Traceback (most recent call last):
  File "/usr/bin/duplicity", line 41, in <module>
    from duplicity import collections
  File "/usr/lib64/python2.6/site-packages/duplicity/collections.py", line 29, in <module>
    from duplicity import path
  File "/usr/lib64/python2.6/site-packages/duplicity/path.py", line 745, in <module>
    from duplicity import gpg
  File "/usr/lib64/python2.6/site-packages/duplicity/gpg.py", line 30, in <module>
    from duplicity import GnuPGInterface
ImportError: cannot import name GnuPGInterface

I installed Duplicity from the OpenSuse Web site as a one click install. It is the latest version (0.6).
Thanks for any assistance you can give.

Peter McCrackan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]