[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building fails on Debian woody because of stupid autoconf wrapper

From: Eli Zaretskii
Subject: Re: Building fails on Debian woody because of stupid autoconf wrapper
Date: Fri, 19 Oct 2001 12:34:15 +0200

> From: address@hidden (Kai =?iso-8859-1?q?Gro=DFjohann?=)
> Date: Fri, 19 Oct 2001 10:56:23 +0200
> address@hidden (Kai Großjohann) writes:
> > Debian woody has Autoconf 2.50 and 2.13 installed and chooses between
> > them based on heuristics.  Part of the heuristics are that it looks
> > for "AC_PREREQ(foo)" where foo is greater than 2.13.
> > 
> > And the aclocal.m4 that comes with Emacs contains AC_PREREQ(2.14)
> > right in the second line...
> The Debian package has now been fixed (for Debian unstable, not sure
> when it will be in Debian testing).

Kai, I'd like to fix that for those who have the previous version of
Debian.  So could you please see if the change below works for you
with the unmodified version of Debian woody?

> So the whole point is moot now, I think.  Sorry for the line-noise.

It was not moot.  Thanks for reporting this.

Index: aclocal.m4
RCS file: /cvs/emacs/aclocal.m4,v
retrieving revision 1.9
diff -c -r1.9 aclocal.m4
*** aclocal.m4  2001/02/20 12:21:12     1.9
--- aclocal.m4  2001/10/19 10:31:49
*** 1,5 ****
- dnl The following are from prerelease autoconf 2.14a.  When 2.14 is
- dnl released, we should be able to zap them and just use AC_PREREQ(2.14).
  % Copyright (C) 2000, 2001  Free Software Foundation, Inc.
--- 1,3 ----

reply via email to

[Prev in Thread] Current Thread [Next in Thread]