emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: utf-translate-cjk-mode question


From: Kenichi Handa
Subject: Re: utf-translate-cjk-mode question
Date: Thu, 1 May 2003 13:45:30 +0900 (JST)
User-agent: SEMI/1.14.3 (Ushinoya) FLIM/1.14.2 (Yagi-Nishiguchi) APEL/10.2 Emacs/21.2.92 (sparc-sun-solaris2.6) MULE/5.0 (SAKAKI)

Sorry for the late response on this matter.

In article <address@hidden>, address@hidden (Kai Gro├čjohann) writes:
> In my ~/.emacs file, I have this piece of code:

> (when (fboundp 'utf-translate-cjk-mode)
>   (let ((current-language-environment "Chinese-GB"))
>     (utf-translate-cjk-mode 1)))

> I start Emacs.  I open a new file.  I say C-u C-\ chinese-py RET.  I
> then type "nihao" into the buffer.  I say C-x RET f utf-8 RET.  Then
> I try to save the buffer.

> Emacs tells me that it can't encode the Chinese characters, and it
> tried iso-latin-1 and utf-8 as encodings, and now it's suggesting
> gb2312 as the encoding to use.

> Is utf-translate-cjk-mode supposed to enable me to store the file as
> utf-8?

Yes, and this bug is my fault.  My previous change to
find-coding-systems-region-internal was incomplete.  I've
just installed a fix.  Please try again with the latest
HEAD.

> The second question contains the code itself.  I tried to just copy
> and paste it from the original defcustom.  But maybe I did something
> wrong.  After loading all the subst-foo files, there is a let
> statement that binds the symbol `table'.  But after this, nothing is
> done with that symbol -- it does not appear to be accessed after
> being populated.  I also looked in version 1.27 (the last version
> before my change), and there, too, the symbol `table' does not appear
> to be accessed.

This is also my fault.  When I made register-char-codings
obsolete, I forgot to delete this unnecessary code.

---
Ken'ichi HANDA
address@hidden




reply via email to

[Prev in Thread] Current Thread [Next in Thread]