[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems with info (emacs version)

From: David Kastrup
Subject: Re: Problems with info (emacs version)
Date: 03 Jun 2003 16:56:10 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

Luc Teirlinck <address@hidden> writes:

> Simon Josefsson wrote:
>    I'd say this is a bug in the mail sending part of Emacs.  Message asks
>    the user if she knows about the hidden parts.
> It does not seem to do that in the concrete example I gave.  I am not
> terribly familiar with message-mode (I use mail-mode), but
> message-mode does not seem to check for or ask about the display
> property.

And I think it shouldn't.  On my eternal todo-list is a way of sending
out formulas as attachments in a buffer.  The formulas should display
as formulas and would be generated with specific commands that would
probably have an MML command covered by display property of the

This should get sent without problems.  On the other hand, _pasting_
stuff with the display property from a different buffer where the
corresponding text for generating the picture might be something
completely different, is not going to be a good idea.

Underlying a display property may be something that only bears
relation to a particular buffer.

Ok, in this case I get saved by a whisker since I actually use
overlays (which don't exist in XEmacs), and overlays are buffer
properties, not text properties.

But the point was: the display property might serve a purpose in a
mail buffer.  Maybe for a specific purpose, one would again use an
overlay (and then be sure that, being generated buffer-specifically,
the covered text is fit for sending in a mail buffer).

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]