[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

broken bootstrap build on 2004 Mar 18

From: Robert J. Chassell
Subject: broken bootstrap build on 2004 Mar 18
Date: Thu, 18 Mar 2004 13:11:51 +0000 (UTC)

Originally, I thought this had to do with the new vc-arch.el file, but
deleting it has no effect.  A newly recreated loaddefs.el file has no
effect either.  I am stumped.

Using today's CVS snapshot, Thu, 2004 Mar 18  12:07 UTC

I was unable to build  GNU Emacs with this command

       (cd "/usr/local/src/emacs/")
        "./configure --with-type1 \
         --with-x-toolkit=gtk --with-pop \
         --prefix=/usr/local --with-sound=yes \
          && time make bootstrap"))

The configure proceeded without reported error, then after starting
the bootstrap, this appeared:

    Loading vc-cvs...
    Loading vc-arch...
    Wrong type argument: stringp, nil
    make[2]: *** [autoloads] Error 255
    make[2]: Leaving directory `/usr/local/src/emacs/lisp'
    make[1]: *** [bootstrap-prepare] Error 2
    make[1]: Leaving directory `/usr/local/src/emacs/lisp'
    make: *** [bootstrap] Error 2

    real        0m0.814s
    user        0m0.480s
    sys 0m0.250s

    Compilation exited abnormally with code 2 at Thu Mar 18 12:12:20

In case there was some problem with byte compiling (not that I
expected any), I byte compiled vc-arch.el manually, with no trouble.
A second `make bootstrap' failed again.

It looks to me that the bug is not in vc-arch.el directly.

As a third experiment, I removed vc-arch.el and vc-arch.elc and ran
another config && make bootstrap command (as shown in the Lisp
expression above).  That build failed, with the same error messages as

As a fourth experiment, I also removed vc-cvs.el and vc-cvs.elc and
suffered the same problem.

In my fifth try, I updated loaddefs.el but that failed, too, with the
same error report.

For your info, I updated loaddefs.el with this defun and the following

(defun bobs-update-autoloads ()
  "Update autoloads in loaddefs.el; a hack."
  (let ((directories '( "."
                        ;; "international"
                        ;; "language"
    (while directories
       (concat "/usr/local/src/emacs/lisp/" (car directories)))
      (setq directories (cdr directories)))))


[Because of problems with several files in the `lisp/international/'
and `lisp/language/' directories, I commented them out.  The reported
bug was

    (scan-error "Unbalanced parentheses" 8384 14043)
      scan-sexps(8384 1)]

 and referenced
 and at least one other.]

As I said, when I tried the config && make bootstrap expression again,
it stopped with the same error report as before.

    Robert J. Chassell                         Rattlesnake Enterprises
    http://www.rattlesnake.com                  GnuPG Key ID: 004B4AC8
    http://www.teak.cc                             address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]