[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Info-index fails on node-name "~/.cvsrc"

From: Eli Zaretskii
Subject: Re: Info-index fails on node-name "~/.cvsrc"
Date: Tue, 18 May 2004 17:17:49 +0200

> From: Juri Linkov <address@hidden>
> Date: Tue, 18 May 2004 14:28:55 +0300
> I already implemented the new Texinfo 4.7 index format in the Emacs
> Info reader a month ago.

Sorry, I didn't know that.  Thank you for your work.

> It uses the (line NNN) format for locating
> index entries:
> * vm-move-messages-physically:           Sorting Messages.    (line   6)
> But an error was caused by some unknown format which is not supported
> neither by the Emacs Info reader nor by the stand-alone reader:
> * vm-move-messages-physically:  Sorting Messages.       5.

Karl, is that maybe some interim version of Texinfo pretest?  If so,
we don't really need to support it in the readers, do we?

> It seems that 5 is a line number.  But the stand-alone reader
> don't interpret it as a line number and simply ignores it.
> I proposed to ignore it in the Emacs reader as well.  But my fix tries
> both variants "Sorting Messages" and "Sorting Messages. 5".  to allow
> possible Info node names with periods in them.  And I suggest to fix
> the stand-alone reader to do the same since currently it fails on such
> node names.

If the stand-alone reader can be fixed to not fail for node names with
periods, I agree.  But if it cannot, I'd rather see the same behavior
in Emacs.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]