[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [unicode-2 branch]emacs can't load library in "zh_CN.gbk" locale

From: zrr
Subject: Re: [unicode-2 branch]emacs can't load library in "zh_CN.gbk" locale
Date: Tue, 05 Oct 2004 00:52:41 +0800
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/21.3.50 (gnu/linux)

Kenichi Handa <address@hidden> writes:

> In article <address@hidden>, zrr <address@hidden> writes:
>>   I have successfully compiled the most recent unicode-2 branch on
>>   my slackware box.(kernel, gcc 3.2.3, glibc-2.3.2)
>>   My default locale is "zh_CN.gbk". When I tried to run emacs with
>>   this command "./src/emacs -q", emacs starts up but complains
>>   "Cannot open load file: tool-bar". Actually, it can't load any
>>   library.
>>   Here is the full error message I have got:
>>     Loading mwheel...done
>>     (./emacs -q)
>>     Failure in loading charset map: "GBK" [5718 times]
>>     command-line: Cannot open load file: tool-barFailure in loading charset 
>> map: "GBK"
>>     Failure in loading charset map: "GBK" [50080 times]
> Thank you for the report.  There was an error in the
> definition of chinese-gbk coding system; it couldn't handle
> ascii. :-(  I've jsut installed a fix.  Please try again.

  Emacs can works in 'zh_CN.gbk' locale now, but it still can't
  handle 'gbk' coding X fonts.

  I have solved this problem by adding following lines in my .emacs

     (add-to-list 'font-encoding-alist '("gbk" . chinese-gbk))
     (add-to-list 'charset-script-alist '(chinese-gbk . han))

  However, maybe you should fix it in the 'fontset.el'.

> ---
> Ken'ichi HANDA
> address@hidden
> _______________________________________________
> Emacs-devel mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/emacs-devel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]