[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: File menu changes (suggestions)

From: Eli Zaretskii
Subject: Re: File menu changes (suggestions)
Date: Mon, 20 Jun 2005 22:37:03 +0200

> From: "Drew Adams" <address@hidden>
> Date: Mon, 20 Jun 2005 09:53:13 -0700
>     We refer to the buffer on purpose: we want users to see Emacs
>     terminology even in the menus, and even when the menus are following
>     established UI guidelines and use standard entries like "New" and
>     "Close".
> Why then do we use Paste instead of Yank?

It's not the same: "buffer" is _in_addition_ to "Save" etc., not
_instead_ of them.

> Menu-item names can serve as a bridge between terms that newbies are used to
> and Emacs terminology.

Exactly: thus "Save Buffer As" includes both the familiar "Save As"
and the reference to "buffer".

>     > a. Currently, there is an inconsistency wrt "Buffer" and
>     "(current buffer)".
>     That's not an inconsistency: in the first case, "Buffer" is part of
>     the command name; in the second, it's a minor comment about the
>     command's operation.
> 1. "Save Buffer As" runs command `write-file'. Where's the beef - er -
> "buffer"?
> 2. "Save (current buffer)" runs command `save-buffer'.
> 3. "Close (current buffer)" runs command `kill-this-buffer'.
> 4. "Revert Buffer" runs command `revert-buffer'.

Wed are miscommunicating: I didn't mean the name of the Lisp function,
I meant the command name that appears in the menu.

> - The command name is irrelevant here.

I disagree.

> - A minor comment about a command's operation belongs perhaps in a tooltip
> or help, but not in the name of the menu item itself.

There were a lot of iterations about this, the current situation was a
compromise between what different people wanted.  Let's not go there

>     > New is better than New File (but see 3, below).
>     No, it is not better, since it doesn't say what new entity is created.
>     Other GUI programs have a submenu there or work only with one type of
>     entities (or just leave it vague, which we didn't want to do).
> So "New File" says that a new file is created? Yes, it says that, but it
> tells not the truth: no file is created by this operation.

A lone "New" isn't better.  I think we didn't find a better

>     > 5. Move all of the window and frame stuff to a new menu, "Frames".
>     Not good: we have a crammed menu bar already, adding more top-level
>     items would only make things worse with no real advantage.
> Agreed. But 1) this stuff has little to do with "File"; 2) use of a
> "Windows" menu, having a similar purpose, is common in other apps;

Richard didn't want that, since in Emacs, `window' means something

> Another possible renaming I forgot to mention is "Split Window". The window
> is not split to result in a single window with a divider. "New Window" would
> be a better name for this menu item.

I think other applications use the same name.  Perhaps just "Split"
would be better, I don't know.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]