[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: address@hidden: Severe hscroll-margin Bug]

From: Markus Gritsch
Subject: Re: address@hidden: Severe hscroll-margin Bug]
Date: Thu, 13 Apr 2006 07:27:11 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv: Gecko/20060130 SeaMonkey/1.0

The Problem described below is still present in current CVS Emacs.

Kim F. Storm wrote:
Both incidents of the bug described below were observed on Windoze
(compiling with mingw).  I tried the recipe on X+GNU/Linux, but cannot
reproduce it.

Can one of the W32 maintainers pls try to reproduce it on their
system -- and possibly debug it to see why it loops.

Markus Gritsch <address@hidden> wrote:

I can now build Emacs from CVS and have done so on 2006-02-21 four days ago. I still get a frozen Emacs wich takes 100% CPU when I use the following .emacs file

(setq-default truncate-lines t)
 '(hscroll-margin 20)
 '(hscroll-step 1)

and resize the Emacs frame to something quite narrow. If you would have another fix, I could probably try it out.

GNU Emacs (i386-mingw-nt5.2.3790) of 2006-02-21 on MGROOVY

Markus also wrote:

When I reported the bug the first time some months ago, David Hunter was also able to reproduce the problem:

.. which says: ... on today's CVS, my mingw build, Windows XP SP2.

This does probably not help very much, but at least I am not the only one, who can reproduce this :)

Does it also loop if you start emacs -Q -D and execute the above
lines directly?


Can you pls. run emacs under gdb and try to interrupt it to see where
it is looping.   You can find instructions in etc/DEBUG.

MGroovy:/cygdrive/c/emacs_CVS/emacs/bin$ gdb emacs.exe
GNU gdb 6.3.50_2004-12-28-cvs (cygwin-special)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-cygwin"...
(gdb) run -Q -D
Starting program: /cygdrive/c/emacs_CVS/emacs/bin/emacs.exe -Q -D
Error: dll starting at 0x78d41000 not found.

Error: dll starting at 0x78d41000 not found.

Error: dll starting at 0x78c31000 not found.

Program received signal SIGINT, Interrupt.
[Switching to thread 4164.0x5b8]
0x7d542a49 in SetConsoleNlsMode ()
(gdb) where
#0  0x7d542a49 in SetConsoleNlsMode ()
#1  0x00000000 in ?? () from
(gdb) list
828     #ifdef VMS
829     , envp
830     #endif
831     )
832          int argc;
833          char **argv;
834     #ifdef VMS
835          char **envp;
836     #endif
837     {

reply via email to

[Prev in Thread] Current Thread [Next in Thread]