[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug] "You can't edit this part of the Custom buffer"

From: Chong Yidong
Subject: Re: [Bug] "You can't edit this part of the Custom buffer"
Date: Fri, 28 Jul 2006 14:14:18 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Richard Stallman <address@hidden> writes:

>     With the old behavior, when you try to insert something in a Customize
>     buffer, you get an error:
>       "Text is read-only: Attempt to change text outside editable field"
>     Now, you get the error:
>       "You can't edit this part of the Custom buffer"
> That was the aim of my change.  It worked right with editable fields,
> but failed with buttons because they don't have their own keymaps.  I
> fixed it.

What do you mean by "worked right with editable fields"?  Without
`custom-no-edit', the "read-only" message pops up anytime you try
inserting in a Custom buffer, not only inside a field (try it).

Your latest change to cus-edit was buggy too---it made self-insert
command keys activate buttons when the cursor is over them.  I changed
`custom-no-edit' back to its old form, and handled "\C-m" by simply
not rebinding it.

> Should buttons work by having their own keymaps?  It seems cleaner
> in principle.

That would require a big reworking of the widget internals.  We can do
this after the release.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]