[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug] "You can't edit this part of the Custom buffer"

From: Richard Stallman
Subject: Re: [Bug] "You can't edit this part of the Custom buffer"
Date: Fri, 28 Jul 2006 22:59:40 -0400

    What do you mean by "worked right with editable fields"?  Without
    `custom-no-edit', the "read-only" message pops up anytime you try
    inserting in a Custom buffer, not only inside a field (try it).

I tried it before, and tried it now -- there is no such problem.

    Your latest change to cus-edit was buggy too---it made self-insert
    command keys activate buttons when the cursor is over them.

Yes, that was a bug.  Sorry.

I'll try it again fixing that.

    > Should buttons work by having their own keymaps?  It seems cleaner
    > in principle.

    That would require a big reworking of the widget internals.  We can do
    this after the release.

I did not have in mind changing it now.  The question is, is that the
right way for things to work?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]